Bug 95204

Summary: After update to El Capitan, Xquartz App doesn't open
Product: XQuartz Reporter: Pedro A. Aranda <paaguti>
Component: OtherAssignee: Jeremy Huddleston Sequoia <jeremyhu>
Status: RESOLVED NOTOURBUG QA Contact: Jeremy Huddleston Sequoia <jeremyhu>
Severity: major    
Priority: medium    
Version: 2.7.8 (xserver-1.16.4)   
Hardware: x86-64 (AMD64)   
OS: Mac OS X (All)   
Whiteboard:
i915 platform: i915 features:

Description Pedro A. Aranda 2016-04-29 11:01:53 UTC
Updates Xquartz to 2.7.8 on Yosemite and everything worked well. After upgrading to El Capitán I observe several things:

Clicking on the icon in my menubar doesn't open XTerm,
'open -a XQuartz' either
'/Applications/Utilities/XQuartz.app/Contents/MacOS/X11' either

Only '/Applications/Utilities/XQuartz.app/Contents/MacOS/X11.bin' ends up by launching the server and launching XTerm

An excerpt of my /var/log/syslog (hope it's enough) that appears periodically


Apr 29 12:45:53 paag org.macosforge.xquartz.X11.stub[15633]: Xquartz: bootstrap_look_up(): Unknown service name
Apr 29 12:45:53 paag org.macosforge.xquartz.startx[15463]: waiting for X server to begin accepting connections
Apr 29 12:45:53 paag org.macosforge.xquartz.startx[15463]: /opt/X11/bin/xinit: giving up
Apr 29 12:45:53 paag org.macosforge.xquartz.startx[15463]: /opt/X11/bin/xinit: unable to connect to X server: Operation timed out
Apr 29 12:45:53 paag org.macosforge.xquartz.startx[15463]: /opt/X11/bin/xinit: server error
Apr 29 12:45:53 paag org.macosforge.xquartz.startx[15463]: /opt/X11/bin/xinit: unable to connect to X server
Apr 29 12:45:53 paag com.apple.xpc.launchd[1] (org.macosforge.xquartz.startx[15463]): FairPlay decryption failed on binary.
Apr 29 12:45:54 paag org.macosforge.xquartz.startx[15700]: xauth:  file /Volumes/Macintosh-HD/Users/paag/.serverauth.15701 does not exist
Apr 29 12:45:54 paag org.macosforge.xquartz.X11.stub[15870]: Xquartz: Unable to locate waiting server: org.macosforge.xquartz.X11
Apr 29 12:45:54 paag org.macosforge.xquartz.X11.stub[15871]: Xquartz: Starting X server: /Applications/Utilities/XQuartz.app/Contents/MacOS/X11 --listenonly
Apr 29 12:45:56 paag org.macosforge.xquartz.startx[15700]:

Apr 29 12:45:58 paag org.macosforge.xquartz.startx[15700]: waiting for X server to begin accepting connections
Comment 1 Jeremy Huddleston Sequoia 2016-04-29 16:23:20 UTC
It sounds like you have a bad ~/.profile or something.  I suggest you start there.
Comment 2 Jeremy Huddleston Sequoia 2016-05-01 23:55:57 UTC
If running X11.bin works but not X11, then that just means that your login environment is causing a problem.  I can't really be more specific than that because that's all that the error indicates.

I suggest you move aside ~/.profile or ~/.bash_profiles or /etc/profiles or other shell init scripts to figure out what the problem is.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.