Bug 97640

Summary: gdbus error shown in apport.log after Thunar crash (reported to savannah.nongnu, too)
Product: dbus Reporter: klsu
Component: coreAssignee: D-Bus Maintainers <dbus>
Status: RESOLVED NOTOURBUG QA Contact: D-Bus Maintainers <dbus>
Severity: normal    
Priority: medium    
Version: unspecified   
Hardware: x86-64 (AMD64)   
OS: Linux (All)   
Whiteboard:
i915 platform: i915 features:
Attachments: What I submitted (and didn't) to http://savannah.nongnu.org/

Description klsu 2016-09-08 15:13:22 UTC
Created attachment 126307 [details]
What I submitted (and didn't) to http://savannah.nongnu.org/

Originally came to submit the crash here, but couldn't find an appropriate product for Thunar; however, noted a gdbus error associated with it.
Comment 1 Simon McVittie 2016-09-08 15:35:10 UTC
(In reply to klsu from comment #0)
> Originally came to submit the crash here, but couldn't find an appropriate
> product for Thunar

That would be because this is the bug tracking system for freedesktop.org projects, and Thunar is not a freedesktop.org project.

I think you want: https://bugzilla.xfce.org/enter_bug.cgi?product=Thunar

I'm not sure why you tried to report this to Savannah; Thunar isn't hosted on Savannah either.

> but I'll probably have to somehow report it there as well because of the apport.log reference to "org.freedesktop...")

That is an error identifier whose meaning is defined by freedesktop.org. It does not mean the error is caused by us. (Analogy: HTTP error 404 is defined by the IETF, but if you get a 404 error from a website, you wouldn't report it to the IETF.)

> gdbus call error: Error: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

I think that might be Apport (a crash-reporting tool) reporting that it tried to ask gnome-session (org.gnome.SessionManager) for more information about the crashing process, and got that error as a response. The error just means that gnome-session isn't available on your D-Bus session bus, and couldn't be started automatically either.

If you expect gnome-session to be running and available on your session bus, and it isn't, then that would be a gnome-session bug.

If you don't expect gnome-session to be running (for instance because you don't even use GNOME), then the fact that it isn't running is not a problem :-)

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.