Bug 97767

Summary: default.pa has 'load-module module-switch-on-port-available' commented out. Output flickering between proper line-out and not-plugged in headphone jack.
Product: PulseAudio Reporter: Mike Lieman <mikelieman>
Component: coreAssignee: pulseaudio-bugs
Status: RESOLVED MOVED QA Contact: pulseaudio-bugs
Severity: critical    
Priority: medium CC: lennart
Version: unspecified   
Hardware: Other   
OS: Linux (All)   
Whiteboard:
i915 platform: i915 features:

Description Mike Lieman 2016-09-11 13:12:23 UTC
Sep 11 09:11:27 orion.lieman.net pulseaudio[1758]: [pulseaudio] device-port.c: Setting port analog-output-headphones to status no
Sep 11 09:11:27 orion.lieman.net pulseaudio[1758]: [pulseaudio] device-port.c: Setting port analog-output-lineout to status yes
Sep 11 09:11:27 orion.lieman.net pulseaudio[1758]: [pulseaudio] module-alsa-card.c: Jack 'Front Headphone Jack' is now unplugged
Sep 11 09:11:27 orion.lieman.net pulseaudio[1403]: [pulseaudio] core-subscribe.c: Dropped redundant event due to change event.
Sep 11 09:11:27 orion.lieman.net pulseaudio[1403]: [pulseaudio] device-port.c: Setting port analog-output-headphones to status no
Sep 11 09:11:27 orion.lieman.net pulseaudio[1403]: [pulseaudio] device-port.c: Setting port analog-output-lineout to status yes
Sep 11 09:11:27 orion.lieman.net pulseaudio[1403]: [pulseaudio] module-alsa-card.c: Jack 'Front Headphone Jack' is now unplugged
Sep 11 09:11:27 orion.lieman.net pulseaudio[1758]: [pulseaudio] core-subscribe.c: Dropped redundant event due to change event.
Sep 11 09:11:27 orion.lieman.net pulseaudio[1403]: [pulseaudio] core-subscribe.c: Dropped redundant event due to change event.
Sep 11 09:11:27 orion.lieman.net pulseaudio[1758]: [pulseaudio] device-port.c: Setting port analog-output-lineout to status no
Sep 11 09:11:27 orion.lieman.net pulseaudio[1403]: [pulseaudio] device-port.c: Setting port analog-output-lineout to status no
Sep 11 09:11:27 orion.lieman.net pulseaudio[1758]: [pulseaudio] device-port.c: Setting port analog-output-headphones to status yes
Sep 11 09:11:27 orion.lieman.net pulseaudio[1403]: [pulseaudio] device-port.c: Setting port analog-output-headphones to status yes
Sep 11 09:11:27 orion.lieman.net pulseaudio[1758]: [pulseaudio] module-alsa-card.c: Jack 'Front Headphone Jack' is now plugged in
Sep 11 09:11:27 orion.lieman.net pulseaudio[1403]: [pulseaudio] module-alsa-card.c: Jack 'Front Headphone Jack' is now plugged in
Sep 11 09:11:26 orion.lieman.net pulseaudio[1758]: [pulseaudio] core-subscribe.c: Dropped redundant event due to change event.
Sep 11 09:11:26 orion.lieman.net pulseaudio[1758]: [pulseaudio] device-port.c: Setting port analog-output-headphones to status no
Sep 11 09:11:26 orion.lieman.net pulseaudio[1403]: [pulseaudio] core-subscribe.c: Dropped redundant event due to change event.
Sep 11 09:11:26 orion.lieman.net pulseaudio[1758]: [pulseaudio] device-port.c: Setting port analog-output-lineout to status yes
Sep 11 09:11:26 orion.lieman.net pulseaudio[1403]: [pulseaudio] device-port.c: Setting port analog-output-headphones to status no
Sep 11 09:11:26 orion.lieman.net pulseaudio[1403]: [pulseaudio] device-port.c: Setting port analog-output-lineout to status yes
Sep 11 09:11:26 orion.lieman.net pulseaudio[1758]: [pulseaudio] module-alsa-card.c: Jack 'Front Headphone Jack' is now unplugged
Sep 11 09:11:26 orion.lieman.net pulseaudio[1403]: [pulseaudio] module-alsa-card.c: Jack 'Front Headphone Jack' is now unplugged
Sep 11 09:11:26 orion.lieman.net pulseaudio[1403]: [pulseaudio] core-subscribe.c: Dropped redundant event due to change event.
Sep 11 09:11:26 orion.lieman.net pulseaudio[1403]: [pulseaudio] device-port.c: Setting port analog-output-lineout to status no
Sep 11 09:11:26 orion.lieman.net pulseaudio[1403]: [pulseaudio] device-port.c: Setting port analog-output-headphones to status yes
Sep 11 09:11:26 orion.lieman.net pulseaudio[1403]: [pulseaudio] module-alsa-card.c: Jack 'Front Headphone Jack' is now plugged in
Sep 11 09:11:26 orion.lieman.net pulseaudio[1758]: [pulseaudio] core-subscribe.c: Dropped redundant event due to change event.
Sep 11 09:11:26 orion.lieman.net pulseaudio[1758]: [pulseaudio] device-port.c: Setting port analog-output-lineout to status no
Sep 11 09:11:26 orion.lieman.net pulseaudio[1758]: [pulseaudio] device-port.c: Setting port analog-output-headphones to status yes
Sep 11 09:11:26 orion.lieman.net pulseaudio[1758]: [pulseaudio] module-alsa-card.c: Jack 'Front Headphone Jack' is now plugged in


Headphones are **NEVER** plugged in.
Comment 1 Tanu Kaskinen 2016-09-15 15:56:09 UTC
It seems like you have faulty hardware that sends bogus jack events. It would be good to have an easy way to disable flickering jacks (or maybe we could do that even fully automatically), but for now disabling a jack requires changes to the files in /usr/share/pulseaudio/alsa-mixer/paths/. The problem with editing those files is that the files will be restored every time your distribution updates the pulseaudio package.

Anyway, if you want to stop PulseAudio from using "Front Headphone Jack", you can remove all "[Jack Front Headphone]" sections from the files in /usr/share/pulseaudio/alsa-mixer/paths/. (Maybe take backups first.)

The bug title says that that you don't have module-switch-on-port-available loaded, but still the output is flickering. What do you mean by that? Does the sink port in pavucontrol flicker, or does the sink port seem to stay the same, but you can hear the flickering, or do you only see some log messages?

If module-switch-on-port-available is not loaded, then the sink port shouldn't flicker in pavucontrol.

If the port stays the same, but you can hear the flickering, that's probably caused by the alsa driver that does auto-muting. Pulseaudio can't do anything about that.

If the log messages are the only problem, you should be able to get rid of those if you edit the path files as described above.
Comment 2 GitLab Migration User 2018-07-30 09:33:22 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/pulseaudio/pulseaudio/issues/10.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.