Bug 97864

Summary: [SNB]GPU hang while playing video in mpv
Product: Mesa Reporter: bugs.fdo
Component: Drivers/DRI/i965Assignee: Intel 3D Bugs Mailing List <intel-3d-bugs>
Status: RESOLVED MOVED QA Contact: Intel 3D Bugs Mailing List <intel-3d-bugs>
Severity: normal    
Priority: medium CC: intel-gfx-bugs
Version: 12.0   
Hardware: x86-64 (AMD64)   
OS: Linux (All)   
Whiteboard:
i915 platform: i915 features:
Attachments: /sys/class/drm/card0/error

Description bugs.fdo 2016-09-19 16:41:43 UTC
Created attachment 126628 [details]
/sys/class/drm/card0/error

System is a laptop with a HD3000 GPU (Intel Sandybridge i5-2520M) running Linux 4.7.3 with Mesa 12.0.3.
I have been playing a video in the mpv player and the moment I double clicked on the screen to exit full screen mode of the player the display froze for a couple of seconds. After that, the following error has been logged.
This exact same issue (GPU hang when switching between full screen/windowed video playback in mpv) has happened before a couple of times already. The issue has occurred with both Compton and the Xfce compositor running. This report is with the Compton compositor running.

[146283.420954] [drm] stuck on render ring
[146283.421664] [drm] GPU HANG: ecode 6:0:0x84fefffc, in compton [18378], reason: Engine(
s) hung, action: reset
[146283.421666] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, incl
uding userspace.
[146283.421667] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI
-> DRM/Intel
[146283.421667] [drm] drm/i915 developers can then reassign to the right component if it'
s not a kernel issue.
[146283.421668] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[146283.421669] [drm] GPU crash dump saved to /sys/class/drm/card0/error
[146283.422959] drm/i915: Resetting chip after gpu hang
[146293.420992] [drm] stuck on render ring
[146293.421659] [drm] GPU HANG: ecode 6:0:0x95effffc, in compton [18378], reason: Engine(s) hung, action: reset
[146293.422997] drm/i915: Resetting chip after gpu hang
Comment 1 Matt Turner 2017-03-22 16:51:06 UTC
I'm using mpv and VAAPI on Sandybridge and I don't see any problems. My config is

% cat ~/.mpv/config 
vo=opengl
hwdec=vaapi
ao=pulse

Can you reproduce with libva-1.7.3 and Mesa 17.0?
Comment 2 GitLab Migration User 2019-09-25 18:58:12 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1539.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.