Bug 100119 - Incorrect dependency on GTK pulled in with SVG backend
Summary: Incorrect dependency on GTK pulled in with SVG backend
Status: RESOLVED INVALID
Alias: None
Product: cairo
Classification: Unclassified
Component: svg backend (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Emmanuel Pacaud
QA Contact: cairo-bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-03-08 18:09 UTC by Davin McCall
Modified: 2018-01-20 11:24 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Patch (656 bytes, patch)
2017-03-08 18:09 UTC, Davin McCall
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Davin McCall 2017-03-08 18:09:53 UTC
Created attachment 130128 [details] [review]
Patch

The configure test for librsvg also checks for gdk-2.0 and this results in gtk being unnecessarily (as far as I can see) linked to cairo. Furthermore it prevents building cairo with the SVG backend enabled if gtk is not present.

This applies to cairo 1.14.8 and current HEAD as far as I can tell.

Note: Please update Bugzilla so that it is possible to report bugs against version 1.14.8 and previous 1.14.x versions.

Patch attached.
Comment 1 Davin McCall 2018-01-20 11:24:14 UTC
After discussion on IRC, am closing this as I think it's invalid. The patch is certainly incorrect and affects tests rather than the main build. I cannot reproduce the original problem (cairo builds linking against gtk).


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.