Bug 100150 - libGL error: failed to load driver: swrast
Summary: libGL error: failed to load driver: swrast
Status: RESOLVED INVALID
Alias: None
Product: XQuartz
Classification: Unclassified
Component: Other (show other bugs)
Version: unspecified
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Jeremy Huddleston Sequoia
QA Contact: Jeremy Huddleston Sequoia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-03-10 17:06 UTC by annarogers
Modified: 2019-05-23 18:27 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Description annarogers 2017-03-10 17:06:27 UTC
Hello,

I have a Mac with the newest version of XQuartz installed. I am trying to launch COMSOL via a ssh to a Linux. I am able to launch other applications, but when I try to launch COMSOL, it gets aborted (error copied below). I have tried multiple versions of XQuartz and the same thing is happening. I also tried the recommendation of "umlimit .." but it still gets aborted.

Thank you for your help, and please let me know if you would like any more information.

Anna 

libGL error: failed to load driver: swrast
libGL error: failed to load driver: swrast
libGL error: failed to load driver: swrast
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x0000000000000000, pid=14604, tid=140409228715840
#
# JRE version: Java(TM) SE Runtime Environment (7.0_75-b13) (build 1.7.0_75-b13)
# Java VM: Java HotSpot(TM) 64-Bit Server VM (24.75-b04 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C  0x0000000000000000
#
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
#
# An error report file with more information is saved as:
# /quake/home/alrogers/hs_err_pid14604.log
#
# If you would like to submit a bug report, please visit:
#   http://bugreport.sun.com/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#
Aborted (core dumped)
Comment 1 Adam Jackson 2019-05-23 18:27:58 UTC
There's not really enough information to work this issue, we would at minimum need a more detailed backtrace for the crash. But the "problematic frame" here doesn't give much to go on, and at any rate suggests that the problem is in how the jvm is invoking the native code. So if you are still experiencing this issue please follow up with your java provider to figure out where the blame properly lies.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.