Bug 100836 - X_GLXMakeContextCurrent using GLX in XQuartz
Summary: X_GLXMakeContextCurrent using GLX in XQuartz
Status: RESOLVED MOVED
Alias: None
Product: XQuartz
Classification: Unclassified
Component: Other (show other bugs)
Version: 2.7.11 (xserver-1.18.4)
Hardware: Other All
: medium normal
Assignee: Jeremy Huddleston Sequoia
QA Contact: Jeremy Huddleston Sequoia
URL:
Whiteboard:
Keywords:
: 103143 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-04-27 07:42 UTC by James
Modified: 2019-05-23 18:28 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Description James 2017-04-27 07:42:11 UTC
Trying to run something that used to run, but I'm now presented with the following.

Any ideas:

-----start--------

Install directory: /Users/james/Downloads/3DE4PLE_osx64_r4
*** oglws v1.0-45, (c) sci-d-vis.com
xp_import_surface: assertion failed: s == NULL
error: xp_import_surface returned: 2
xp_destroy_surface: assertion failed: s != NULL
xp_destroy_surface error: 3
X Error of failed request:  0
  Major opcode of failed request:  149 (GLX)
  Minor opcode of failed request:  26 (X_GLXMakeContextCurrent)
  Serial number of failed request:  78
  Current serial number in output stream:  78
logout
Saving session...
...copying shared history...
...saving history...truncating history files...
...completed.
Comment 1 James 2017-04-28 07:27:57 UTC
Forgot to mention

Running on Macbook pro (mid 2015) Os Sierra version 10.12.4
Comment 2 James 2017-04-28 07:30:51 UTC
Also forgot to mention, I've tried removing xquartz via the following commands and reinstalling it.

~~~~commands ~~~~~
launchctl unload /Library/LaunchAgents/org.macosforge.xquartz.startx.plist
sudo launchctl unload /Library/LaunchDaemons/org.macosforge.xquartz.privileged_startx.plist
sudo rm -rf /opt/X11* /Library/Launch*/org.macosforge.xquartz.* /Applications/Utilities/XQuartz.app /etc/*paths.d/*XQuartz
sudo pkgutil --forget org.macosforge.xquartz.pkg
~~~~

I've also removed Wine (if that conflicts or not, I don't know)

I'm at my wits end! It was working last month. Incidentally, I did update xcode command line tools the same day.
Comment 3 Andre Klapper 2017-08-14 19:38:41 UTC
Please provide a minimal, self-contained test case.
Comment 4 Jeremy Huddleston Sequoia 2017-10-08 19:11:41 UTC
*** Bug 103143 has been marked as a duplicate of this bug. ***
Comment 5 GitLab Migration User 2019-05-23 18:28:26 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xorg/xserver/issues/751.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.