Bug 10136 - xutils/wincopy doesn't work with direct rendering on i965
Summary: xutils/wincopy doesn't work with direct rendering on i965
Status: VERIFIED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: haihao
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-02-28 20:17 UTC by Peter Cordes
Modified: 2009-08-24 12:26 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Description Peter Cordes 2007-02-28 20:17:06 UTC
progs/xutils/wincopy only draws in the first window on i965.  The second window remains black.  It says it uses  glxMakeContextCurrent()  to copy to the second window.  If I run it with LIBGL_ALWAYS_INDIRECT, the second window updates (or not, if I hit f to toggle target=front/back buffer.)

 If this is intentional behaviour because it's a waste of time to be correct for something nobody uses, then that's just fine with me.  I'm just reporting that this demo shows a difference between the software renderer and the i965 renderer, in case you weren't aware of it.  I don't do GL programming, so I don't really know what it means. :/

 Basically, feel free to close this with minimal explanation if appropriate.
Comment 1 he jiang 2007-08-23 18:12:38 UTC
The bug can be reproduced on i965 platform.
Comment 2 he jiang 2007-08-23 18:26:51 UTC
But when LIBGL_ALWAYS_INDIRECT was set, the second window remains black, without any updates(I didn't hit f to toggle target=front/back buffer.)
Comment 3 Michael Fu 2007-08-23 18:37:51 UTC
re-assign to haihao
Comment 4 haihao 2007-08-29 00:08:02 UTC
fixed in git
mesa commit: bad6e175cf59cce630c37d73f6e71f3a4de50ae6.

BTW. A window manager is needed, or the case can't get Expose event.
Comment 5 he jiang 2007-08-29 02:18:52 UTC
The bug can't be reproduced on i965 platform.
Comment 6 Adam Jackson 2009-08-24 12:26:01 UTC
Mass version move, cvs -> git


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.