Bug 101549 - fprintd PAM module ignores SIGINT
Summary: fprintd PAM module ignores SIGINT
Status: RESOLVED MOVED
Alias: None
Product: libfprint
Classification: Unclassified
Component: fprintd (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: medium normal
Assignee: libfprint-bugs
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-06-21 20:39 UTC by liu.denton
Modified: 2018-05-31 08:58 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
PAM module ignoring ^C (1.24 KB, image/png)
2017-06-21 20:39 UTC, liu.denton
Details

Note You need to log in before you can comment on or make changes to this bug.
Description liu.denton 2017-06-21 20:39:50 UTC
Created attachment 132123 [details]
PAM module ignoring ^C

Summary
-------

When attempting to authenticate using the fprintd PAM module, there is no way to quit out without waiting for the verification timeout to occur.

Expected Behaviour
------------------

Sending SIGINT (via ^C) should cause the authentication to immediately fail.

Actual Behaviour
----------------

Sending SIGINT (via ^C) does not do anything. Authentication only fails after timeout period expires.

Additional Information
----------------------

Currently running fprintd 0.7.0+12+ge55ad52-3 installed from the Arch Linux repos.
Comment 1 Bastien Nocera 2017-06-21 20:59:59 UTC
There's nothing in the module's source code intercepting signals, so it must be something in one of the dependencies. A backtrace of the blocked service, as well as a debug output would be good first steps.
Comment 2 liu.denton 2017-06-22 00:32:18 UTC
Sorry, I haven't debugged PAM modules before so I am currently learning how to grab the stacktrace and debug output. If anyone could provide any advice on this, it'd be appreciated.

Meanwhile, I used the pamtester utility to attempt to debug this and I discovered that I can ^C just fine when I run `pamtester sudo $USER authenticate`.

Where I'm encountering the issue is when I'm actually attempting to do something using sudo, itself. For example, `sudo echo hi`.

The following are the contents to my `/etc/pam.d/sudo`, if this helps.
```
#%PAM-1.0
auth        sufficient  pam_fprintd.so
auth		include		system-auth
account		include		system-auth
session		include		system-auth
```
Comment 3 Bastien Nocera 2018-05-09 15:08:59 UTC
(In reply to liu.denton from comment #2)
> Sorry, I haven't debugged PAM modules before so I am currently learning how
> to grab the stacktrace and debug output. If anyone could provide any advice
> on this, it'd be appreciated.

It's the same as getting the backtrace of any other program. Please check with your distribution for how exactly to get all the necessary debugging symbols installed.
Comment 4 GitLab Migration User 2018-05-31 08:58:11 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/libfprint/fprintd/issues/6.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.