Bug 10169 - X.org doesn't detect widescreen resolutions
Summary: X.org doesn't detect widescreen resolutions
Status: RESOLVED NOTOURBUG
Alias: None
Product: xorg
Classification: Unclassified
Component: * Other (show other bugs)
Version: 7.2 (2007.02)
Hardware: Other All
: medium normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-03-03 02:39 UTC by Alexander van Loon
Modified: 2007-03-03 04:28 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander van Loon 2007-03-03 02:39:47 UTC
Please see this Ubuntu bug: https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/63551

This has already been affecting me for a long time. My latest installed version of Ubuntu is 6.10, which has X.org 7.1. I have a Dell 20" 2007WFP widescreen monitor with a resolution of 1680x1050 which is connected to my NVIDIA 7800GT. After I installed Ubuntu 6.10, the resolution which was automatically configured was 1280x1024, and to change my resolution to the correct 1680x1050 I had to add the resolution manually to xorg.conf.
Most recently I tried the Ubuntu 7.04 Herd 5 LiveCD which has X.org 7.2. Even though 7.2 is supposed to have improved autoconfiguration, it still detected a 1280x1024 resolution.

Please, could this be fixed so that X.org properly detects widescreen resolutions? Ubuntu is supposed to be a Linux distro for the masses, but newbies will be scared if they have to edit xorg.conf just to get the correct widescreen resolution.
Comment 1 Daniel Stone 2007-03-03 03:01:31 UTC
X.Org is capable of detecting these just fine.  Ubuntu has its own configuration tool, though (7.2's improved autoconfiguration involves having _no_ xorg.conf), which frequently misdetects LCD resolutions.

(Blame me, 'cause I wrote it.)
Comment 2 Alexander van Loon 2007-03-03 04:20:03 UTC
Thank you for your quick reply. But if X.org is capable of detecting widescreen resolutions just fine, then is Ubuntu's configuration tool the cause of picking the wrong resolution? Do I understand this correctly, that this is Ubuntu's fault and not X.org's fault? If I would try a LiveCD of for example openSUSE or Fedora,  the resolution would likely be detected correctly? 
Comment 3 Daniel Stone 2007-03-03 04:28:10 UTC
yep, it is indeed ubuntu's fault.  i don't know if fedora or suse would work, since suse for one certainly has its own configuration tool, but maybe.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.