Bug 10192 - r100 r200: Regression from 6.5.1 games rendering single texture or pixel at bottom left only
Summary: r100 r200: Regression from 6.5.1 games rendering single texture or pixel at b...
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/r200 (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL: http://homeworldsdl.org/
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-03-05 15:05 UTC by Alan Swanson
Modified: 2009-08-24 12:26 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
hw-r200-comparison.jpg (40.82 KB, image/jpeg)
2007-03-05 15:07 UTC, Alan Swanson
Details
r100-r200-bug9876-bug10109.patch (3.47 KB, patch)
2007-03-11 06:45 UTC, Alan Swanson
Details | Splinter Review
r200-simplify-r200setcliprects.patch (4.66 KB, patch)
2007-03-11 06:45 UTC, Alan Swanson
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Alan Swanson 2007-03-05 15:05:25 UTC
I was recently testing Homeworld SDL on my R200 which works on Mesa 6.5.1 but from Mesa 6.5.2 up to the current git it only renders a single texture at the bottom left of the screen on the main menu or a single pixel at the bottom left of the screen in game.

Testing on a i855GME with Mesa git was successful so looks to be a R200 only problem.

Unfortunately Homeworld SDL is not quite open as you need to register with the Relic Developers Network before the project admins would grant SVN access. The registration is basically so the code will not be used commercially and Relic can own all changes to the code. (The original release can actually now officially be downloaded without this restriction from various sites though obviously would a different beast from the current code.)

Checking all my games, the only other affected one is Darwinia which includes its demo.
Comment 1 Alan Swanson 2007-03-05 15:07:44 UTC
Created attachment 8990 [details]
hw-r200-comparison.jpg

A comparitive screenshot of the main menu in Homeworld SDL. On the left is on Mesa 6.5.1 and on the right is on Mesa 6.5.2 and current git.

(A comparitive screenshot of the single pixel at bottom left in game would be pretty worthless.)
Comment 2 Roland Scheidegger 2007-03-05 15:56:04 UTC
git-bisect should be able to find the change which caused it to fail. Even if the source would be available, it wouldn't really help as for playing you need the original CD, and it's probably easier to track this down automatically with git-bisect rather than trying to figure out what the game does what causes it to fail.
Comment 3 Alan Swanson 2007-03-08 12:01:38 UTC
Git bisecting points to "Remove use of GetBufferSize (depreciated)" in commit c7228ce8e48fc634759b99740282a62457942539 as the problem.

http://gitweb.freedesktop.org/?p=mesa/mesa.git;a=commit;h=8f6a50a49cd3b7479d1cfcf195b53e6d9b0800dd

Applying the patch for r200 from comment 11 in bug 9876 derived from the r300 patch commited by Michel Dänzer resolves the problem so closing this as a duplicate (but a patch still needs commited).

*** This bug has been marked as a duplicate of bug 9876 ***
Comment 4 Alan Swanson 2007-03-11 06:44:39 UTC
Since bug 9876 for r300 is closed, which I'd missed, I'm reopening this bug for the same fix still needing to be commited to radeon and r200 as they are the origin code base of r300 as suffer the same problem.

Attached will be a patch which also integrates the related fix from bug 10109 and has been tested successfully on a R200, rv250 and a R100.

There's also a second patch to copy the simplification of radeonSetCliprects() in commit 6e7aebfe39bdd9c9fecb03ca3b0b617c2b449c8 from radeon to r200. Again, tested successfully on a R200 and rv250.
Comment 5 Alan Swanson 2007-03-11 06:45:16 UTC
Created attachment 9084 [details] [review]
r100-r200-bug9876-bug10109.patch
Comment 6 Alan Swanson 2007-03-11 06:45:45 UTC
Created attachment 9085 [details] [review]
r200-simplify-r200setcliprects.patch
Comment 7 Michel Dänzer 2007-03-12 01:06:00 UTC
Pushed, thanks.
Comment 8 Adam Jackson 2009-08-24 12:26:06 UTC
Mass version move, cvs -> git


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.