Bug 10304 - resolution proper but size of things (fonts) broken with intel driver on 852GM - acer notebook
Summary: resolution proper but size of things (fonts) broken with intel driver on 852G...
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: 7.2 (2007.02)
Hardware: Other All
: medium normal
Assignee: Eric Anholt
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
: 12581 12784 13458 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-03-15 02:21 UTC by Arkadiusz Miskiewicz
Modified: 2009-08-03 11:27 UTC (History)
11 users (show)

See Also:
i915 platform:
i915 features:


Attachments
screenshot of broken kdm screen (360.26 KB, image/jpeg)
2007-03-15 02:22 UTC, Arkadiusz Miskiewicz
no flags Details
used xorg.conf (2.97 KB, text/plain)
2007-03-15 02:22 UTC, Arkadiusz Miskiewicz
no flags Details
X log (66.70 KB, text/plain)
2007-03-15 02:23 UTC, Arkadiusz Miskiewicz
no flags Details
running xrandr serveral times, one run after another shows different results (1.05 KB, text/plain)
2007-03-15 02:23 UTC, Arkadiusz Miskiewicz
no flags Details
proposed fix for physical size detection (7.67 KB, patch)
2007-08-09 14:09 UTC, Eric Anholt
no flags Details | Splinter Review
patch to ry (875 bytes, patch)
2007-10-09 00:14 UTC, Hong Liu
no flags Details | Splinter Review
Xorg.0.log (63.06 KB, text/plain)
2007-10-11 05:11 UTC, Chí-Thanh Christopher Nguyễn
no flags Details
Xorg.0.log (44.39 KB, text/plain)
2007-10-12 06:49 UTC, Chí-Thanh Christopher Nguyễn
no flags Details
xdpyinfo (6.00 KB, text/plain)
2007-10-12 06:50 UTC, Chí-Thanh Christopher Nguyễn
no flags Details
crashed xorg-server 1.4 (33.96 KB, application/octet-stream)
2007-10-24 03:14 UTC, alium
no flags Details
crashed xorg-server 1.4 log (33.96 KB, application/octet-stream)
2007-10-24 03:14 UTC, alium
no flags Details
better patch - xserver works ( Xorg.0.log) (38.12 KB, text/plain)
2007-10-25 03:30 UTC, alium
no flags Details
xorg.conf with right set DisplaySize and "Monitor-outputname" "monitorsection" (2.94 KB, text/plain)
2007-10-25 08:48 UTC, alium
no flags Details
xdpyinfo with fixed DPI (6.18 KB, text/plain)
2007-10-25 08:49 UTC, alium
no flags Details
ModeDebug On (76.79 KB, application/octet-stream)
2009-04-01 11:52 UTC, alium
no flags Details
Xorg log (30.12 KB, text/plain)
2009-05-08 12:40 UTC, Orion Poplawski
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Arkadiusz Miskiewicz 2007-03-15 02:21:40 UTC
The problem began here:
http://lists.freedesktop.org/archives/xorg/2007-February/021847.html

Today we tested latest xserver (1.2.99.902) and intel driver (1.99.92).

Everything starts, the flickering no longer happens but now font size is crazy. Switching back to i810 driver with the same xserver curses problem.

Also xrandr shows sometimes that VGA output is connected (while it is not), later for one or two seconds that it's not connected and then again that it's connected.
Comment 1 Arkadiusz Miskiewicz 2007-03-15 02:22:24 UTC
Created attachment 9149 [details]
screenshot of broken kdm screen
Comment 2 Arkadiusz Miskiewicz 2007-03-15 02:22:53 UTC
Created attachment 9150 [details]
used xorg.conf
Comment 3 Arkadiusz Miskiewicz 2007-03-15 02:23:09 UTC
Created attachment 9151 [details]
X log
Comment 4 Arkadiusz Miskiewicz 2007-03-15 02:23:52 UTC
Created attachment 9152 [details]
running xrandr serveral times, one run after another shows different results
Comment 5 Eric Anholt 2007-03-15 14:02:45 UTC
OK, we can get that fixed.  Can you provide a physical measurement of your panel size (in mm)?
Comment 6 Arkadiusz Miskiewicz 2007-03-15 22:57:32 UTC
DisplaySize	  330   210	# mm

these are real values measured manually :)
Comment 7 Przemysław Plewa 2007-03-27 23:31:17 UTC
Still doesn’t work witch xserver (1.2.99.903) and intel driver (1.9.93)
Comment 8 Przemysław Plewa 2007-04-03 02:55:44 UTC
Still doesn’t work with xserver (1.2.99.903) and intel driver (1.9.94)
Comment 9 Arkadiusz Miskiewicz 2007-04-20 14:10:34 UTC
Unfortunately the problem persist with xserver 1.3.0 and intel driver 2.0.0. Is this issue really so hard? :-)
Comment 10 Johannes Engel 2007-05-14 09:31:57 UTC
*** Bug 10756 has been marked as a duplicate of this bug. ***
Comment 11 Eric Anholt 2007-08-09 14:09:15 UTC
Created attachment 11068 [details] [review]
proposed fix for physical size detection

Could you test the attached patch against a current server?
Comment 12 Przemysław Plewa 2007-08-14 03:21:50 UTC
Unfortunately the problem persist with xserver 1.3.0 and intel driver 2.1.1 with your patch
Comment 13 Michael Fu 2007-08-23 18:43:20 UTC
Eric to respond...
Comment 14 Hong Liu 2007-10-09 00:14:23 UTC
Created attachment 11949 [details] [review]
patch to ry

This patch prefers the user configured DisplaySize to the probed DDC data, please add the actual physical size to your xorg.conf monitor section and have a try.
Comment 15 Alex Deucher 2007-10-09 06:47:53 UTC
(In reply to comment #14)
> Created an attachment (id=11949) [details]
> patch to ry
> 
> This patch prefers the user configured DisplaySize to the probed DDC data,
> please add the actual physical size to your xorg.conf monitor section and have
> a try.
> 

This patch needs probably go upstream anyway (should go in 1.4.1 as well) as there are often cases when we don't know the physical size of an output and need to specify it.  See bug 12474 for example.
Comment 16 Chí-Thanh Christopher Nguyễn 2007-10-11 05:11:45 UTC
Created attachment 11987 [details]
Xorg.0.log

Same problem here on Acer 5022 with Mobility Radeon X700, xserver 1.3.0.0 and latest xf86-video-ati from git
Comment 17 Alex Deucher 2007-10-11 16:41:59 UTC
*** Bug 12784 has been marked as a duplicate of this bug. ***
Comment 18 Chí-Thanh Christopher Nguyễn 2007-10-11 16:51:30 UTC
The problem is not caused by the driver, but by bad EDID data from the panel. Bytes 66-67 (image size in mm) are simply copied over from bytes 21-22 (panel size in cm) which is obviously incorrect.
Comment 19 Eric Anholt 2007-10-11 17:01:33 UTC
I believe I've fixed the EDID issue upstream now (confused your issue with a very similar one).  Please retest.
Comment 20 Alex Deucher 2007-10-11 17:18:35 UTC
*** Bug 12581 has been marked as a duplicate of this bug. ***
Comment 21 Chí-Thanh Christopher Nguyễn 2007-10-12 06:49:33 UTC
Created attachment 12011 [details]
Xorg.0.log

The problem still persists, even with the patch from http://gitweb.freedesktop.org/?p=xorg/xserver.git;a=commit;h=fc092334ac0a323b80a9602cb8bf60ca9dee3bfa

In Xorg.0.log the EDID quirk is mentioned, but xdpyinfo still shows wrong dpi (and fonts are huge)
Comment 22 Chí-Thanh Christopher Nguyễn 2007-10-12 06:50:41 UTC
Created attachment 12012 [details]
xdpyinfo

xdpyinfo output
Comment 23 Michael Fu 2007-10-23 17:43:15 UTC
could anybody post a test result of patch in comment# 14?
Comment 24 alium 2007-10-24 03:11:04 UTC
(In reply to comment #23)
> could anybody post a test result of patch in comment# 14?
> 

Yes, i patch this patcg again Archlinux xorg-server 1.4 :
  

# Patches from redhat:
  patch -Np3 -i ${startdir}/src/xorg-redhat-die-ugly-pattern-die-die-die.patch 
  patch -Np0 -i ${startdir}/src/xorg-x11-server-0.99.3-init-origins-fix.patch 
  patch -Np1 -i ${startdir}/src/xorg-x11-server-1.0.1-Red-Hat-extramodes.patch 
  patch -Np0 -i ${startdir}/src/xorg-x11-server-1.1.0-no-move-damage.patch 
  patch -Np1 -i ${startdir}/src/xorg-x11-server-1.1.1-vbe-filter-less.patch 
  patch -Np1 -i ${startdir}/src/xorg-x11-server-1.1.1-no-scanpci.patch 
  patch -Np1 -i ${startdir}/src/xserver-1.3.0-newglx-offscreen-pixmaps.patch 

  # Own patches
  patch -Np1 -i ${startdir}/src/xorg-server-1.2.0-defaultdpi.patch 
  patch -Np1 -i ${startdir}/src/prefer-displaysize.patch
  
  aclocal
  autoconf
  automake --add-missing
  ./configure --prefix=/usr \
              --with-mesa-source=${startdir}/src/Mesa-${_mesaver} \
              --enable-ipv6 \
              --enable-dri \
              --enable-dmx \
              --enable-xvfb \
              --enable-xnest \
              --enable-composite \
              --enable-xcsecurity \
              --enable-xorg \
              --enable-xtrap \
              --enable-xevie \
	      --enable-xephyr \
              --enable-glx-tls \
	      --disable-kdrive \
              --enable-install-setuid \
              --disable-xprint \
              --sysconfdir=/etc/X11 \
              --localstatedir=/var \
              --with-default-font-path=/usr/share/fonts/misc,/usr/share/fonts/100dpi:unscaled,/usr/share/fonts/75dpi:unscaled,/usr/share/fonts/TTF,/usr/share/fonts/Type1 \
              --with-rgb-path=/usr/share/X11/rgb \
              --with-xkb-path=/usr/share/X11/xkb \
              --with-xkb-output=/usr/share/X11/xkb/compiled \
              --with-dri-driver-path=/usr/lib/xorg/modules/dri \
              --disable-static

  make || return 1
  make DESTDIR=${startdir}/pkg install || return 1
  mkdir -p ${startdir}/pkg/etc/X11
  mkdir -p ${startdir}/pkg/var/lib
  mv ${startdir}/pkg/usr/share/X11/xkb/compiled ${startdir}/pkg/var/lib/xkb
  ln -sf /var/lib/xkb ${startdir}/pkg/usr/share/X11/xkb/compiled

  cd ${startdir}/pkg/usr/lib/xorg/modules/extensions
  mv libGLcore.so libGLcore.xorg
  mv libglx.so libglx.xorg

  # prevent conflict with nvidia-utils
  mv ${startdir}/pkg/usr/lib/xorg/modules/libwfb.so \
     ${startdir}/pkg/usr/lib/xorg/modules/libwfb.so.1.4
-------------------------------------------------------------

ARCH x86_64

kernel 2.6.23
dbus 1.1.2
hal 0.5.10
xf86-video-intel 2.1.1 
xorg 1.4
GCC 4.2.2
pixman 0.9.5
-----------------------------------------------------------------

Result:  X server not starting, crash!

Backtrace:
0: X(xf86SigHandler+0x6a) [0x48d0ba]
1: /lib/libc.so.6 [0x2b8cc69517b0]
2: X(xf86RandR12CreateScreenResources+0x1ee) [0x4b2a5e]
3: X [0x4ada9f]
4: X(main+0x319) [0x4367d9]
5: /lib/libc.so.6(__libc_start_main+0xf4) [0x2b8cc693eae4]
6: X(FontFileCompleteXLFD+0x261) [0x435c79]

Fatal server error:
Caught signal 11.  Server aborting


please see Xorg.0.log - DPI is not anyway (96,96) , but (96,154) 
Comment 25 alium 2007-10-24 03:14:03 UTC
Created attachment 12171 [details]
crashed xorg-server 1.4
Comment 26 alium 2007-10-24 03:14:55 UTC
Created attachment 12172 [details]
crashed xorg-server 1.4 log

crashed xorg-server 1.4 log
Comment 27 Arkadiusz Miskiewicz 2007-10-24 03:17:06 UTC
Confirming.

We tested #14 when it appeared but the server crashed. Unfortunately we had no debug symbols compiled in so we weren't able to dig deeper what's the cause. Now I see that the patch was problematic as crash happens for others, too.
Comment 28 Stefan Dirsch 2007-10-24 10:14:17 UTC
Looks like you're not using a monitor section at all or do not specify it properly with 

  Option "Monitor-outputname" "monitorsection"

Still it's a bug in the patch of comment #14, since you get a Nullpointer
reference when not using a monitor section. This should not happen. I stumbled
across this today as well ...

Better version of this patch:

diff --git a/hw/xfree86/modes/xf86RandR12.c b/hw/xfree86/modes/xf86RandR12.c
index 38435c9..135356d 100644
--- a/hw/xfree86/modes/xf86RandR12.c
+++ b/hw/xfree86/modes/xf86RandR12.c
@@ -426,8 +426,18 @@ xf86RandR12CreateScreenResources (ScreenPtr pScreen)
            xf86OutputPtr   output = config->output[config->compat_output];
            xf86CrtcPtr     crtc = output->crtc;
 
-           if (crtc && crtc->mode.HDisplay &&
-               output->mm_width && output->mm_height)
+           if (output->conf_monitor &&
+               (output->conf_monitor->mon_width  > 0 ||
+                output->conf_monitor->mon_height > 0))
+           {
+               /*
+                * Prefer user configured DisplaySize
+                */
+               mmWidth = output->conf_monitor->mon_width;
+               mmHeight = output->conf_monitor->mon_height;
+           }
+           else if (crtc && crtc->mode.HDisplay &&
+                    output->mm_width && output->mm_height)
            {
                /*
                 * If the output has a mode and a declared size, use that





Comment 29 Matthias Hopf 2007-10-24 11:31:45 UTC
I committed a slightly modified version of this patch (a monitor section with either width or height <= 0 shouldn't be honored as well).
But I think the original issue is still open.
Comment 30 alium 2007-10-25 03:22:33 UTC
(In reply to comment #29)

it's a good thing, thanks! Xserver not crashed. 

-------------------------------------------------------------------------------
I use new add (for my laptop) in xorg.conf for  Option "Monitor-outputname" "monitorsection" :

Section "Monitor"
        Identifier      "LCD 1280x800"
        Option          "DPMS"          "true"
	VendorName	"LPL"
	DisplaySize     338 211
	Option 		"Monitor-LVDS " "LVDS  monitor"
EndSection
-------------------------------------------------------------------------------

Results : xserver 1.4 with "better" patch set display dimensions now right :
(**) intel(0): Display dimensions: (338, 211) mm   

but DPI is set wrong - DPI is now 96,154.
Comment 31 alium 2007-10-25 03:30:19 UTC
Created attachment 12180 [details]
better patch - xserver works ( Xorg.0.log)
Comment 32 Alex Deucher 2007-10-25 06:01:46 UTC
(In reply to comment #30)
> 
> Results : xserver 1.4 with "better" patch set display dimensions now right :
> (**) intel(0): Display dimensions: (338, 211) mm   
> 
> but DPI is set wrong - DPI is now 96,154.
> 

check xdpyinfo.  you dpi should be correct. the (**) intel(0): DPI set to (96, 154) line is misleading in that it takes into account the virtual size of the desktop when it prints that.  The xrandr code does the right thing however.
Comment 33 alium 2007-10-25 07:47:46 UTC
(In reply to comment #32)

OK, results from xdpyinfo:

# xdpyinfo |grep resolution
 resolution:    112x968 dots per inch
 
the font is huge

---------------------------------------------------------

when i use  # xrandr --fbmm 338x211 : (338x211 is physical size of my laptop´s display)


# xdpyinfo |grep resolution
  resolution:    96x96 dots per inch
the font is correct


Comment 34 Stefan Dirsch 2007-10-25 08:19:44 UTC
>Section "Monitor"
>        Identifier      "LCD 1280x800"
>        Option          "DPMS"          "true"
>        VendorName      "LPL"
>        DisplaySize     338 211
>        Option          "Monitor-LVDS " "LVDS  monitor"
>EndSection
Isn't the monitor Option line just wrong? Shouldn't this be

  Option          "monitor-LVDS " "LCD 1280x800"

instead?
Comment 35 alium 2007-10-25 08:32:23 UTC
(In reply to comment #34)
> >Section "Monitor"
> >        Identifier      "LCD 1280x800"
> >        Option          "DPMS"          "true"
> >        VendorName      "LPL"
> >        DisplaySize     338 211
> >        Option          "Monitor-LVDS " "LVDS  monitor"
> >EndSection
> Isn't the monitor Option line just wrong? Shouldn't this be
> 
>   Option          "monitor-LVDS " "LCD 1280x800"
> 
> instead?
> 


Yes, right !! I am idiot, sorry.

If i use "better" patch + in xorg.conf DisplaySize + Option "Monitor-outputname" "monitorsection" the dpi is correct !! 96dpi, no huge wrong DPI.

The problem is fixed.

Can another make test for confirmation?
Comment 36 alium 2007-10-25 08:48:31 UTC
Created attachment 12190 [details]
xorg.conf with right set DisplaySize and "Monitor-outputname" "monitorsection"
Comment 37 alium 2007-10-25 08:49:39 UTC
Created attachment 12191 [details]
xdpyinfo with fixed DPI
Comment 38 Stefan Dirsch 2007-10-25 09:29:05 UTC
Since Matthias pushed the fix upstream, let's finally close this one as fixed.
Comment 39 Stefan Dirsch 2007-10-25 09:29:17 UTC
Since Matthias pushed the fix upstream, let's finally close this one as fixed.
Comment 40 alium 2007-10-25 09:59:30 UTC
Thanks to all !
Comment 41 Paul Dufresne 2007-11-23 18:04:39 UTC
Here on Ubuntu we have the bug:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/107320

It seems we have someone with a similar but not identical monitor.

servaas-xubuntu-user, bug #127827
(II) intel(0): Manufacturer: LPL Model: 2a00 Serial#: 0 (near miss!)
(II) intel(0): Setting screen physical size to 289 x 21
servaas-xubuntu-user (Problem in XUbuntu in general, not just GDM)
X Window System Version 1.3.0
X Protocol Version 11, Revision 0, Release 1.3
Current Operating System: Linux ubuntu 2.6.22-8-generic #1 SMP Thu Jul 12 15:59:45 GMT 2007 i686
(==) intel(0): DPI set to (75, 75)

His bug is reported in Ubuntu at:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/127827
and it's Xorg.0.log file is at:
http://launchpadlibrarian.net/8675708/Xorg.0.log

My believe is that the patch should be modified to add this monitor model (2a00).

We also have 1 person with detected 40x30 mm screen, and one with 10mmx10mm screen. I don't think they are related to this bug, but if curious more info is at: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/151311/comments/29
Comment 42 Matthias Hopf 2007-11-30 09:03:20 UTC
*** Bug 13458 has been marked as a duplicate of this bug. ***
Comment 43 Tormod Volden 2009-04-01 11:16:30 UTC
Alois, can you please add Option "ModeDebug" "true" to your xorg.conf and attach the new log? Apparently there are several panels from Philips with product ID = 0 and not all of them need this quirk. I am wondering if there is some more identification we can use.
Comment 44 alium 2009-04-01 11:29:57 UTC
(In reply to comment #43)
> Alois, can you please add Option "ModeDebug" "true" to your xorg.conf and
> attach the new log? Apparently there are several panels from Philips with
> product ID = 0 and not all of them need this quirk. I am wondering if there is
> some more identification we can use.
> 

	
yes, but now using xorg-server 1.6 and xf86-video-intel 2.6.99.902

will have any influence?
Comment 45 alium 2009-04-01 11:52:08 UTC
Created attachment 24444 [details]
ModeDebug On
Comment 46 Orion Poplawski 2009-05-08 12:38:56 UTC
Reopening as there seems to be other models affected.  I'll attach the Xorg.0.log with ModeDebug on for my system as well.
Comment 47 Orion Poplawski 2009-05-08 12:40:10 UTC
Created attachment 25646 [details]
Xorg log

xorg-x11-drv-ati-6.12.2-11.fc11.x86_64

HP Pavilion zv6000
Comment 48 Eric Anholt 2009-08-03 11:27:48 UTC
This bug report is way too big.  The original bug should be fixed, and the reporter no longer has the hardware.  If people have bugs with other monitors, please open your own bugs so you actually get some attention!


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.