Bug 103223 - Massive screen corruption on KMS startup under kernel-PAE-4.13.4-200.fc26.i686 in Acer Aspire One ZG5
Summary: Massive screen corruption on KMS startup under kernel-PAE-4.13.4-200.fc26.i68...
Status: CLOSED DUPLICATE of bug 102931
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: x86 (IA32) Linux (All)
: medium critical
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-10-11 15:22 UTC by Alex Villacís Lasso
Modified: 2017-10-26 16:54 UTC (History)
1 user (show)

See Also:
i915 platform: I965G
i915 features: display/Other


Attachments
journalctl of affected kernel (228.38 KB, text/plain)
2017-10-11 15:22 UTC, Alex Villacís Lasso
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Villacís Lasso 2017-10-11 15:22:30 UTC
Created attachment 134797 [details]
journalctl of affected kernel

Kernel: kernel-PAE-core-4.13.4-200.fc26.i686
Machine: Acer Aspire One ZG5
Video outputs: one LCD display 1024x600, one VGA port with no monitor attached.

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GSE Express Integrated Graphics Controller (rev 03) (prog-if 00 [VGA controller])
	Subsystem: Acer Incorporated [ALI] Device 015b
	Flags: bus master, fast devsel, latency 0, IRQ 16
	Memory at 58480000 (32-bit, non-prefetchable) [size=512K]
	I/O ports at 60c0 [size=8]
	Memory at 40000000 (32-bit, prefetchable) [size=256M]
	Memory at 58500000 (32-bit, non-prefetchable) [size=256K]
	[virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
	Capabilities: <access denied>
	Kernel driver in use: i915
	Kernel modules: i915

This is the same machine affected in bug https://bugs.freedesktop.org/show_bug.cgi?id=98930 .

After updating to distro kernel 4.13.4 or 4.13.5, and rebooting, boot is normal until KMS takes over, then the display on the LCD gets garbled in a square area (800x800) at the left of the screen. The garbled area persists during the rest of the startup and into the login screen and makes the display unusable.

Previous kernel kernel-PAE-4.12.14-300.fc26.i686 does not garble the display, although it still shows a backtrace as described in #98930, as this is the exact same machine.

Version-Release number of selected component (if applicable):
kernel-PAE-4.13.4-200.fc26.i686

How reproducible:
Always

Steps to Reproduce:
1. Acer Aspire One ZG5 32-bit with Fedora 26 and kernel-PAE-4.13.4-200.fc26.i686
2. Boot with updated kernel
3.

Actual results:
Garbled screen in a square section when KMS takes over.

Expected results:
No screen corruption.

Additional info:
Using journalctl I have captured a dmesg output of the affected kernel. Look for the string "plane B assertion failure, should be off on pipe B but is still active".
Comment 1 Serhiy Zahoriya 2017-10-23 00:46:02 UTC
Looks like

*** This bug has been marked as a duplicate of bug 102931 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.