Bug 103603 - Scroll doesn't work while moving mouse in VirtualBox
Summary: Scroll doesn't work while moving mouse in VirtualBox
Status: RESOLVED MOVED
Alias: None
Product: xorg
Classification: Unclassified
Component: Input/libinput (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Peter Hutterer
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-06 22:28 UTC by yaroslav.sapozhnik
Modified: 2018-08-10 20:56 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description yaroslav.sapozhnik 2017-11-06 22:28:23 UTC
Running Fedora 26 in VirtualBox 5.2.0 with libinput 1.9.0 the mouse scroll is not registered in Chrome and Firefox browsers while moving mouse. 

If the mouse is stationary the scroll events pass through fine. This happens in  browser windows and in system terminal (xfce-terminal), but works in Java application.
Comment 1 Peter Hutterer 2017-11-07 05:32:25 UTC
what's the output of sudo libinput debug-events when scrolling?
Comment 2 yaroslav.sapozhnik 2017-11-07 13:11:30 UTC
Output while moving mouse:

 event6   POINTER_MOTION_ABSOLUTE  +8.78s	 63.40/ 55.07
 event6   POINTER_MOTION_ABSOLUTE  +8.78s	 63.47/ 54.93
 event6   POINTER_MOTION_ABSOLUTE  +8.79s	 63.55/ 54.93
-event3   POINTER_AXIS      +8.79s	vert -15.00* horiz 0.00 (wheel)
-event6   POINTER_MOTION_ABSOLUTE  +8.81s	 63.62/ 54.93
 event6   POINTER_MOTION_ABSOLUTE  +8.82s	 63.69/ 54.93
 event6   POINTER_MOTION_ABSOLUTE  +8.83s	 63.84/ 55.36
 event6   POINTER_MOTION_ABSOLUTE  +8.84s	 64.21/ 56.53
 event6   POINTER_MOTION_ABSOLUTE  +8.85s	 64.80/ 58.87
 event6   POINTER_MOTION_ABSOLUTE  +8.86s	 65.68/ 61.49
 event6   POINTER_MOTION_ABSOLUTE  +8.86s	 66.56/ 64.56
 event6   POINTER_MOTION_ABSOLUTE  +8.87s	 67.52/ 67.92
 event6   POINTER_MOTION_ABSOLUTE  +8.88s	 68.40/ 72.59
 event6   POINTER_MOTION_ABSOLUTE  +8.88s	 69.06/ 76.39
-event3   POINTER_AXIS      +8.88s	vert 15.00* horiz 0.00 (wheel)
-event6   POINTER_MOTION_ABSOLUTE  +8.89s	 69.50/ 79.74
 event6   POINTER_MOTION_ABSOLUTE  +8.90s	 69.80/ 81.93
-event3   POINTER_AXIS      +8.90s	vert 15.00* horiz 0.00 (wheel)
-event6   POINTER_MOTION_ABSOLUTE  +8.91s	 69.94/ 83.10
 event6   POINTER_MOTION_ABSOLUTE  +8.92s	 69.94/ 83.39
-event3   POINTER_AXIS      +8.93s	vert 15.00* horiz 0.00 (wheel)
-event6   POINTER_MOTION_ABSOLUTE  +8.93s	 69.94/ 83.54
 event6   POINTER_MOTION_ABSOLUTE  +8.94s	 69.80/ 83.54
-event3   POINTER_AXIS      +8.94s	vert 15.00* horiz 0.00 (wheel)

Output if mouse stationary:

-event3   POINTER_AXIS     +21.06s	vert -15.00* horiz 0.00 (wheel)
 event3   POINTER_AXIS     +21.98s	vert -15.00* horiz 0.00 (wheel)
 event3   POINTER_AXIS     +22.87s	vert -15.00* horiz 0.00 (wheel)
 event3   POINTER_AXIS     +30.54s	vert 15.00* horiz 0.00 (wheel)
Comment 3 Peter Hutterer 2017-11-07 23:46:54 UTC
looks like this isn't a libinput bug because the POINTER_AXIS events still come through from libinput, intermixed with the positioning data. Confirmed by your comment that it works in java but not in other application. libinput doesn't know which applications are running, so the issue is somewhere else.

One way to test this further is using xev and moving on top of the xev window. Check what events are being sent, same approach with xinput test-xi2. It's possible that the server does not send the correct event sequence or something.
Comment 4 yaroslav.sapozhnik 2017-11-08 16:43:23 UTC
Thanks for the reply and pointing in other direction. I've been confused by the discussion on VBox forum claiming the issue appeared after switching from evdev to libinput. However the evdev experience the same symptoms. 

Sorry for taking you time and thanks again!

Regards,
Yaroslav
Comment 5 Peter Hutterer 2017-11-08 22:36:18 UTC
no worries, closing this bug
Comment 6 yaroslav.sapozhnik 2017-11-30 16:17:17 UTC
Sorry for posting into the closed bug, but I've been able to pinpoint the issue to the xorg-x11-drv-libinput.x86_64 package. If I remove this package the scroll works fine.

The issue lies somewhere between VBox Guest Additions and libinput driver for x11. 

Any ideas what might be the cause?
Comment 7 Peter Hutterer 2017-11-30 22:18:30 UTC
strange. run xinput test-xi2 and move into the window, then reproduce the issue. What's the output from xinput?
Comment 8 yaroslav.sapozhnik 2017-12-01 15:54:26 UTC
I've spent some time playing with xinput and removing/installing libinput-drv.

The only difference is that when driver installed the output for moving mouse has more classes:

diff tmp/no-libinput tmp/with-libinput 
4c4
< 	Reporting 3 classes:
---
> 	Reporting 7 classes:
6,7c6,7
< 		Buttons supported: 5
< 		Button labels: "Button Left" "Button Unknown" "Button Unknown" "Button Wheel Up" "Button Wheel Down"
---
> 		Buttons supported: 7
> 		Button labels: "Button Left" "Button Middle" "Button Right" "Button Wheel Up" "Button Wheel Down" "Button Horiz Wheel Left" "Button Horiz Wheel Right"
> 		Class originated from: 9. Type: XIValuatorClass
> 		Detail for Valuator 2:
> 		  Label: Rel Horiz Scroll
> 		  Range: -1.000000 - -1.000000
> 		  Resolution: 0 units/m
> 		  Mode: relative
> 		Class originated from: 9. Type: XIValuatorClass
> 		Detail for Valuator 3:
> 		  Label: Rel Vert Scroll
> 		  Range: -1.000000 - -1.000000
> 		  Resolution: 0 units/m
> 		  Mode: relative
> 		Class originated from: 9. Type: XIScrollClass
> 		Scroll info for Valuator 2
> 		  type: 2 (horizontal)
> 		  increment: 15.000000
> 		  flags: 0x0
> 		Class originated from: 9. Type: XIScrollClass
> 		Scroll info for Valuator 3
> 		  type: 1 (vertical)
> 		  increment: 15.000000
> 		  flags: 0x0

Those changes are for

EVENT type 1 (DeviceChanged)
    device: 2 (9)
    reason: SlaveSwitch
Comment 9 yaroslav.sapozhnik 2017-12-01 16:44:28 UTC
Ok, I've found another post where disabling xinput2 scrolling in chrome fixes the issue at https://bbs.archlinux.org/viewtopic.php?id=223470
Comment 10 GitLab Migration User 2018-08-10 20:56:56 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xorg/driver/xf86-input-libinput/issues/9.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.