Bug 104707 - XQuartz 2.7.11 fails to launch on Mac Sierra 10.12.6
Summary: XQuartz 2.7.11 fails to launch on Mac Sierra 10.12.6
Status: RESOLVED MOVED
Alias: None
Product: XQuartz
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 2.7.11 (xserver-1.18.4)
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Jeremy Huddleston Sequoia
QA Contact: Jeremy Huddleston Sequoia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-19 19:46 UTC by mmoore
Modified: 2019-05-23 18:32 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Description mmoore 2018-01-19 19:46:22 UTC
XQuartz stopped working after having worked fine for a long time. I checked some obvious things like my $PATH to see if something stepped on it but didn't find any discernible difference from what I had previously.

$ echo $PATH /usr/local/bin:/usr/local/sbin:/bin:/sbin:/usr/bin:/usr/sbin:/usr/libexec:/usr/X11/bin:/usr/local/opt/python/libexec/bin:/Library/Frameworks/Python.framework/Versions/3.4/bin

So, after looking at what seems like a million suggestions I uninstalled with the commands listed at: https://gist.github.com/pwnsdx/d127873e24cef159d4d603accaf37ee4

After reinstalling with XQuartz-2.7.11.dmg I try launching XQuartz.app by right clicking it in a finder window but it doesn't launch. The only indication of a problem I can see is when launching the XQuartz.app I get the following:

$ tail -f /private/var/log/system.log | grep xquartz
Jan  5 17:26:33 bos-mpx3u com.apple.xpc.launchd[1] >(org.macosforge.xquartz.X11.24980[2612]): Service exited with abnormal code: 126

So, I've tried uninstalling and reinstalling XQuartz-2.7.9.dmg, reinstalling XQuartz-2.7.11.dmg and even reinstalling via $ brew cask install xquartz but I always get the same results.
Comment 1 GitLab Migration User 2019-05-23 18:32:22 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xorg/xserver/issues/799.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.