Bug 105559 - Non-working emacs blocks compile
Summary: Non-working emacs blocks compile
Status: RESOLVED MOVED
Alias: None
Product: desktop-file-utils
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Hans Petter Jansson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-16 17:42 UTC by John
Modified: 2018-11-12 15:15 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Description John 2018-03-16 17:42:41 UTC
I tried to compile and install the last desktop-file-utils package when I bumped into this error:

if test "emacs" != "no"; then \
	  am__dir=. am__subdir_includes=''; \
	  case desktop-entry-mode.elc in */*) \
	    am__dir=`echo 'desktop-entry-mode.elc' | sed 's,/[^/]*$,,'`; \
	    am__subdir_includes="-L $am__dir -L ./$am__dir"; \
	  esac; \
	  test -d "$am__dir" || /usr/bin/mkdir -p "$am__dir" || exit 1; \
	  emacs --batch \
	      \
	    $am__subdir_includes -L . -L . \
	    --eval "(defun byte-compile-dest-file (f) \"desktop-entry-mode.elc\")" \
	    --eval "(unless (byte-compile-file \"desktop-entry-mode.el\") (kill-emacs 1))"; \
	else :; fi
emacs: error while loading shared libraries: libMagickWand-6.Q16.so.1: cannot open shared object file: No such file or directory
-------
I had to recompile ImageMagick last week, and I never use emacs, so I didn't notice that it is linked to the so.1 version (the new version created .so.2).

Is it possible to skip things emacs related? Maybe a configure option? I couldn't find any solution, short from editing configure by hand?

Cheers
Comment 1 John 2018-03-16 17:49:37 UTC
I made a wild guess and ran   EMACS=no ./configure ...
and this worked - desktop-file-validate was correctly installed.

I didn't close the bug (feel free to do so), because I still think
this should be either documented or implemented as a configure
option.

Thanks for all the good work!
Comment 2 GitLab Migration User 2018-11-12 15:15:59 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xdg/desktop-file-utils/issues/15.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.