Bug 105841 - HDMI/DP audio is not supported on GLK
Summary: HDMI/DP audio is not supported on GLK
Status: CLOSED DUPLICATE of bug 102937
Alias: None
Product: PulseAudio
Classification: Unclassified
Component: alsa (show other bugs)
Version: unspecified
Hardware: Other All
: medium critical
Assignee: pulseaudio-bugs
QA Contact: pulseaudio-bugs
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-04-02 06:06 UTC by qwang13
Modified: 2018-04-10 02:21 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description qwang13 2018-04-02 06:06:05 UTC
Platform information:
Label: GLK02SDP
Processor: Silver N5000
Bios: GELKRVPA.X64.0083.B30.1801162142
OS: Ubuntu 18.04
Kernel: 4.15.0-10-generic

Details:
1 )Check the audio driver
root@GLK02:~# lspci -xxx -s e.0 -v 
00:0e.0 Multimedia audio controller: Intel Corporation Device 3198 (rev 03)
        Subsystem: Intel Corporation Device 7270
        Flags: bus master, fast devsel, latency 0, IRQ 152
        Memory at a1214000 (64-bit, non-prefetchable) [size=16K]
        Memory at a1000000 (64-bit, non-prefetchable) [size=1M]
        Capabilities: [50] Power Management version 3
        Capabilities: [80] Vendor Specific Information: Len=14 <?>
        Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
        Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
        Kernel driver in use: snd_hda_intel
        Kernel modules: snd_hda_intel, snd_soc_skl
2) Check the audio playback device;

**** List of PLAYBACK Hardware Devices ****
Home directory not accessible: Permission denied
card 0: PCH [HDA Intel PCH], device 0: ALC298 Analog [ALC298 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

==> only legacy Analog device is in the list.
Comment 1 qwang13 2018-04-02 06:07:59 UTC
This issue is reproduced on Ubuntu 18.04 (kernel v4.15), REL 7.5, SUSE-SLE15.
Comment 2 Tanu Kaskinen 2018-04-02 06:41:13 UTC
If the device isn't visible in alsa, pulseaudio can't do anything about that. Try reporting the problem to the alsa developers:
http://alsa-project.org/main/index.php/Bug_Tracking
Comment 3 qwang13 2018-04-10 02:20:07 UTC
duplicated bug 
https://bugs.freedesktop.org/show_bug.cgi?id=102937
Comment 4 qwang13 2018-04-10 02:21:05 UTC

*** This bug has been marked as a duplicate of bug 102937 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.