Bug 105931 - X11R6 directory no longer present
Summary: X11R6 directory no longer present
Status: RESOLVED WORKSFORME
Alias: None
Product: XQuartz
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 2.7.11 (xserver-1.18.4)
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Alun J. Carr
QA Contact: Jeremy Huddleston Sequoia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-04-06 19:47 UTC by Alun J. Carr
Modified: 2018-04-06 20:26 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
macOS system log (1.45 KB, text/plain)
2018-04-06 19:51 UTC, Alun J. Carr
Details

Description Alun J. Carr 2018-04-06 19:47:28 UTC
XQuartz 2.7.11 on macOS 10.13.4 (High Sierra) with an APFS-formatted system disk.

In earlier releases a /usr/X11R6 directory (possibly a symlink, but maybe an HFS+ hardline) was present in addition to /usr/X11, but this has now disappeared, breaking some legacy scientific software that uses /usr/X11R6, for which source code is not available.

Because of the very tight security in recent releases of macOS, I can no longer create a symlink from /usr/X11 to /usr/X11R6.

I haven't used the software for a while, but I'm sure that it worked with macOS 10.12.x (Sierra) with an HFS+ system disk.

If the XQuartz team could create a suitable symlink on their next release, or persuade Apple to put one in place, that would be absolutely spiffing!

Best regards,

Alun
Comment 1 Alun J. Carr 2018-04-06 19:51:32 UTC
Created attachment 138662 [details]
macOS system log

macOS system log showing problem.
Comment 2 Jeremy Huddleston Sequoia 2018-04-06 20:26:45 UTC
Use /usr/libexec/x11-select to create it.  That's done during X11 install, but it is undone when the OS is upgraded.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.