Bug 106181 - Laptop with i915 GPU hangs changing screen brightness with kernel 4.16.x, 4.15 fine.
Summary: Laptop with i915 GPU hangs changing screen brightness with kernel 4.16.x, 4.1...
Status: CLOSED NOTOURBUG
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-04-23 06:15 UTC by Öyvind Saether
Modified: 2018-04-24 15:22 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Description Öyvind Saether 2018-04-23 06:15:20 UTC
My laptop has the 
VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09)
on the Intel(R) Core(TM) i7-5500U CPU. It uses the i915. This laptop would totally freeze in Xorg shortly after logging into lightdm after upgrading to Fedora 28 with kernel 4.16.3. I found that kernel 4.15.17 from FC27 works perfectly. After wasting too much time investigating I found that disabling redshift would allow me to login. Adjusting the display brightness with them hotkeys makes it totally freeze immediately. No logs are written, no switching to terminal, no SSHing into the box, no nothing, it's just dead. I can therefore not provide more useful information unless someone tells me what to provide or how.

What I do know is that for sure is that with kernel 4.16 adjusting the display brightness makes the laptop totally freeze and that's probably what makes it freeze when redshift is running. This does not happen on kernel 4.15. This is probably a regression or problem with i915 but it could also be some problem with the power management kernel options Fedora changed in this kernel but that does not seem likely. I did try screwing around with the various /sys stuff after doing a diff of the kernel configs and changing things does not appear to make a difference.
Comment 1 Öyvind Saether 2018-04-24 13:27:40 UTC
Further investigation and testing on this laptop with Fedora 4.16.2 and 4.16.4 and comparing configurations with 4.15.17 reveals that this Fedora configuration change is the cause:

< CONFIG_SATA_MOBILE_LPM_POLICY=0
> CONFIG_SATA_MOBILE_LPM_POLICY=3

which can be fixed by adding this kernel boot parameter:

ahci.mobile_lpm_policy=1

(I guess 0 would work to, but /sys/class/scsi_host/host*/link_power_management_policy was set to max_performance with 0 on 4.15.17)

One Obvious Question: Why would having this set to 3 (med_power_with_dipm) make the laptop hang immediately when changing the Screen Brightness manually (or when redshift is running)? This seems counterintuitive and very very strange.

I can reproduce this 100%. I can even do this on 4.15.17,
for powercontrol in /sys/class/scsi_host/host*/link_power_management_policy ; do
  echo 'min_powermin_power' > $powercontrol
done
and make that one hang by changing the screen brightness. I do not understand.
Comment 2 Jani Saarinen 2018-04-24 15:22:41 UTC
Thanks.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.