Bug 10812 - Xorg crashes when changing to a text console.
Summary: Xorg crashes when changing to a text console.
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Eric Anholt
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-04-29 12:46 UTC by Raúl
Modified: 2007-09-19 11:59 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Xorg log for the crash. (50.70 KB, text/x-log)
2007-04-29 12:47 UTC, Raúl
no flags Details
Core dump backtrace. (1.89 KB, text/plain)
2007-04-29 12:47 UTC, Raúl
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Raúl 2007-04-29 12:46:27 UTC
I log into the X session, after kde have done some start work I change to a text console (VT), in that moment Xorg crashes. If I go back to the graphical session I see the login manager again. I use kdm/kde.

My system is a Dell inspiron 510m laptop running Debian unstable but with intel driver compiled by myself from git.

I attach the Xorg log and the bactrace of the core dump.
Comment 1 Raúl 2007-04-29 12:47:00 UTC
Created attachment 9798 [details]
Xorg log for the crash.
Comment 2 Raúl 2007-04-29 12:47:25 UTC
Created attachment 9799 [details]
Core dump backtrace.
Comment 3 Raúl 2007-07-02 15:52:25 UTC
I think https://bugs.freedesktop.org/show_bug.cgi?id=11269 is a duplicate of this one. What do you think?

I'll also try to provide up-to-date info with the latest git version.
Comment 4 Gordon Jin 2007-09-03 20:15:17 UTC
Raul, how about the result with the latest git?
Comment 5 Keith Packard 2007-09-06 18:57:23 UTC
There was a cursor image reference counting bug which should be fixed in X server version 1.4. That should fix this problem. Please reopen if it still crashes.
Comment 6 Raúl 2007-09-07 01:15:20 UTC
Sorry for the delay, this is just to say that I haven't forgot about, it's just I'm solving some issues prior to this, but this is quite on top on my queue.

I'll try to report about next week.

Thanks.
Comment 7 Raúl 2007-09-16 09:20:02 UTC
I'm waiting for 1.4 to enter into Debian sid. I'll confirm this after trying that.
Comment 8 Raúl 2007-09-19 11:59:38 UTC
Great! It works :)


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.