Bug 108247 - Piglit tests 'clip-distance-redeclare-without-inout.frag' and 'clip-distance-redeclare-without-inout.vert' fail
Summary: Piglit tests 'clip-distance-redeclare-without-inout.frag' and 'clip-distance-...
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-05 08:10 UTC by asimiklit
Modified: 2019-01-25 09:32 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Description asimiklit 2018-10-05 08:10:52 UTC
Piglit tests:
'clip-distance-redeclare-without-inout.frag'
'clip-distance-redeclare-without-inout.vert'
always fail.

At the moment these tests are marked as an expected failure:
https://github.com/janesma/mesa_jenkins/blob/master/piglit-test/kbl.conf

But as far as I understood following mailing thread:
https://lists.freedesktop.org/archives/piglit/2013-October/007935.html
looks like we have accepted to remove an ability to change qualifiers
but have not done it yet.

I have created some possible solution:
https://patchwork.freedesktop.org/patch/254818/
So what do you think about it this fix?

Note: 
This patch leads to regression in 'clip-distance-out-values.shader_test'
but probably a fix should be made in this test.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.