Bug 108704 - 4.19 amdgpu Tonga powerplay regressions
Summary: 4.19 amdgpu Tonga powerplay regressions
Status: RESOLVED NOTOURBUG
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/AMDgpu (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
: 108778 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-11-10 13:29 UTC by Daniel Scharrer
Modified: 2018-12-04 12:04 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
dmesg output (65.90 KB, text/plain)
2018-11-10 13:29 UTC, Daniel Scharrer
no flags Details
lspci -vvxx output under 4.18.17-gentoo (73.48 KB, text/plain)
2018-11-21 00:35 UTC, Daniel Scharrer
no flags Details
dmesg output on Arch Linux (85.88 KB, text/plain)
2018-11-26 21:55 UTC, Laurent Pointecouteau
no flags Details
sudo lspci -vvxxx on 4.19.2-arch1-1-ARCH (70.16 KB, text/plain)
2018-11-26 21:57 UTC, Laurent Pointecouteau
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Scharrer 2018-11-10 13:29:32 UTC
Created attachment 142423 [details]
dmesg output

With Gentoo's 4.19.0 and 4.19.1 kernels, powerplay does not seem to be working on my Radeon R9 380X card: 3D applications run noticeably slower than before (but otherwise work fine) and there a number of errors in dmesg during startup and when trying to switch dpm states via sysfs.

Everything works fine with 4.18.17-gentoo.
Comment 1 Alex Deucher 2018-11-12 15:30:10 UTC
Does this patch fix the issue?
https://patchwork.freedesktop.org/patch/259364/
Comment 2 Alex Deucher 2018-11-12 15:33:17 UTC
If not, can you bisect?
Comment 3 adamcarter3 2018-11-14 11:28:22 UTC
FYI the patch did fix the same issue for me with an R9 380
Comment 4 Alex Deucher 2018-11-19 19:12:53 UTC
*** Bug 108778 has been marked as a duplicate of this bug. ***
Comment 5 Bjorn Helgaas 2018-11-20 15:09:18 UTC
Could somebody please attach "sudo lspci -vvxxx" output for an affected system (for at least the root port and GPU, or the whole system if that's easier)?
Comment 6 Daniel Scharrer 2018-11-21 00:35:28 UTC
Created attachment 142530 [details]
lspci -vvxx output under 4.18.17-gentoo
Comment 7 Laurent Pointecouteau 2018-11-26 21:55:27 UTC
Created attachment 142617 [details]
dmesg output on Arch Linux

I think I'm affected by a similar issue. I'm using an AMD R9 380 on Arch Linux with the latest GNOME version. My main troubles are with dual-screen, which started malfunctioning some days ago - maybe since the 4.19 kernel update, although I'm unable to downgrade to an older kernel to confirm this.
Comment 8 Laurent Pointecouteau 2018-11-26 21:57:16 UTC
Created attachment 142618 [details]
sudo lspci -vvxxx on 4.19.2-arch1-1-ARCH
Comment 9 Alex Deucher 2018-11-26 22:03:07 UTC
Please try the patch in comment 1.
Comment 10 Laurent Pointecouteau 2018-12-01 17:17:24 UTC
(In reply to Alex Deucher from comment #9)
> Please try the patch in comment 1.

I've applied the patch and there are no more amdgpu related errors showing up in dmesg after booting. However, this has not fixed my dual-screen issues; my HDMI TV displays "no signal" after booting while plugged in my computer, and when trying to switch display modes using the GNOME control center, my DVI screen tends to get disabled and display "no signal" too, forcing me to hard reboot. As far as I can tell, this is the same behavior than before using the patched kernel. So, my issues may not be related to this bug ticket after all.
Comment 11 Alex Deucher 2018-12-03 03:12:06 UTC
(In reply to Laurent Pointecouteau from comment #10)
> (In reply to Alex Deucher from comment #9)
> > Please try the patch in comment 1.
> 
> I've applied the patch and there are no more amdgpu related errors showing
> up in dmesg after booting. However, this has not fixed my dual-screen
> issues; my HDMI TV displays "no signal" after booting while plugged in my
> computer, and when trying to switch display modes using the GNOME control
> center, my DVI screen tends to get disabled and display "no signal" too,
> forcing me to hard reboot. As far as I can tell, this is the same behavior
> than before using the patched kernel. So, my issues may not be related to
> this bug ticket after all.

Please file a different bug for the display issue.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.