Bug 109553 - pt layout fails to load after xkeyboard-config update to 2.26-1
Summary: pt layout fails to load after xkeyboard-config update to 2.26-1
Status: RESOLVED MOVED
Alias: None
Product: freedesktop.org
Classification: Unclassified
Component: Bugzilla (show other bugs)
Version: unspecified
Hardware: Other All
: medium major
Assignee: fd.o Admin Massive
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-02-05 06:01 UTC by joao.filipe.santos
Modified: 2019-02-05 09:20 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
patch to the /usr/share/X11/xkb/symbols/pt that fixes the bug (5.25 KB, patch)
2019-02-05 06:01 UTC, joao.filipe.santos
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description joao.filipe.santos 2019-02-05 06:01:42 UTC
Created attachment 143298 [details] [review]
patch to the /usr/share/X11/xkb/symbols/pt that fixes the bug

Description:
After doing a complete system upgrade and rebooting my pc, running "setxkbmap pt" (and similar commands) failed to load the Portuguese (PT not BR) keyboard layout, producing the following error message "Error loading new keyboard description".
Reverting to the previous version of the package fixed the problem.

I did some digging and it seems a pt version for the colemak keyboard was added at the end of the file: usr/share/X11/xkb/symbols/pt
As it turns out the lines pertaining to the colemak keyboard add some `` and an unrelated line before the colemak configuration also had an weird value. One or both of those things were causing the layout to load. Changing them fixed the problem.
Applying the attached patch to that file should fix the problem.

I am not sure if this is an upstream bug or was somehow introduced by the build, as I'm not skilled enough to fully understand the program or the build process.
I humbly ask for your help with this issue.

* config and/or log files etc. Attached is a patch that fixed the bug.

Steps to reproduce:
On an arch-linux system with xkeyboard-config 2.26-1 run:
setxkbmap pt
Comment 1 Daniel Stone 2019-02-05 09:20:03 UTC
Thanks a lot, but xkeyboard-config now handles patches and submissions in GitLab instead: https://gitlab.freedesktop.org/xkeyboard-config/xkeyboard-config/issues/new


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.