Bug 112043 - i915 still "Resetting rcs0 for hang on rcs0" on Linus' tip of 0e2adab6cf285
Summary: i915 still "Resetting rcs0 for hang on rcs0" on Linus' tip of 0e2adab6cf285
Status: RESOLVED MOVED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: Triaged
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-18 03:27 UTC by Kenneth C
Modified: 2019-11-29 19:41 UTC (History)
1 user (show)

See Also:
i915 platform: CFL
i915 features: GPU hang


Attachments
/sys/class/drm/card0/error (5.05 KB, text/plain)
2019-10-18 03:27 UTC, Kenneth C
no flags Details

Description Kenneth C 2019-10-18 03:27:26 UTC
Created attachment 145767 [details]
/sys/class/drm/card0/error

More of the same hang. At least now it seems to recover, but these GPU hangs are from the drm-next of mid-September; the branch I have with those changes carved out is rock-solid.
Comment 1 Lakshmi 2019-10-19 07:21:57 UTC
(In reply to Kenneth C from comment #0)
> Created attachment 145767 [details]
> /sys/class/drm/card0/error
> 
> More of the same hang. At least now it seems to recover, but these GPU hangs
> are from the drm-next of mid-September; the branch I have with those changes
> carved out is rock-solid.

Do you see the same issue from drmtip branch?
Comment 2 Kenneth C 2019-10-21 05:34:17 UTC
(In reply to Lakshmi from comment #1)

> Do you see the same issue from drmtip branch?

Unfortunately I cannot use drm-tip as it breaks power-management during S0 suspend (see bug https://bugs.freedesktop.org/show_bug.cgi?id=111909).
Comment 3 Lakshmi 2019-10-24 07:26:21 UTC
(In reply to Kenneth C from comment #2)
> (In reply to Lakshmi from comment #1)
> 
> > Do you see the same issue from drmtip branch?
> 
> Unfortunately I cannot use drm-tip as it breaks power-management during S0
> suspend (see bug https://bugs.freedesktop.org/show_bug.cgi?id=111909).

Can you disable GUC and reproduce the issue?
Comment 4 Kenneth C 2019-10-24 15:43:11 UTC
(In reply to Lakshmi from comment #3)

> Can you disable GUC and reproduce the issue?

You'd asked me to disable GuC a while ago for another manifestation of this same bug and it made no difference: https://bugs.freedesktop.org/show_bug.cgi?id=111920

I'm in the middle of a dev cycle right now and can't take time yet to attempt to see if the bugs in drm-tip are fixed, so I've been running Linus' master with all drm/i915 changes since late September yanked out (which runs perfectly now).

Maybe on the weekend I'll pull drm-tip and see if this and the power-management issue (https://bugs.freedesktop.org/show_bug.cgi?id=111909) work any better, though.
Comment 5 Martin Peres 2019-11-29 19:41:49 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/drm/intel/issues/523.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.