Bug 112135 - [CI][RESUME]igt@kms_flip@flip-vs-suspend - dmesg-warn - *ERROR* Restoring old state failed with -22
Summary: [CI][RESUME]igt@kms_flip@flip-vs-suspend - dmesg-warn - *ERROR* Restoring ol...
Status: RESOLVED WORKSFORME
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: not set not set
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-25 11:55 UTC by Lakshmi
Modified: 2019-11-06 18:32 UTC (History)
1 user (show)

See Also:
i915 platform: TGL
i915 features: display/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lakshmi 2019-10-25 11:55:06 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_7144/re-tgl-u/igt@kms_flip@flip-vs-suspend.html
<3> [1367.318852] [drm:intel_display_resume [i915]] *ERROR* Restoring old state failed with -22
Comment 1 CI Bug Log 2019-10-25 11:55:49 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* TGL:  igt@kms_flip@flip-vs-suspend - dmesg-warn -  *ERROR* Restoring old state failed with -22
  - https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_7144/re-tgl-u/igt@kms_flip@flip-vs-suspend.html
Comment 2 CI Bug Log 2019-10-28 08:17:21 UTC
A CI Bug Log filter associated to this bug has been updated:

{- TGL:  igt@kms_flip@flip-vs-suspend - dmesg-warn -  *ERROR* Restoring old state failed with -22 -}
{+ KBL TGL:  Random tests - dmesg-warn -  *ERROR* Restoring old state failed with -22 +}

New failures caught by the filter:

  * https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_7172/shard-kbl6/igt@gem_workarounds@suspend-resume-fd.html
Comment 3 Ville Syrjala 2019-10-28 14:41:24 UTC
<7> [1291.127757] [drm:intel_dp_start_link_train [i915]] [CONNECTOR:307:DP-3] Link Training Passed at Link Rate = 810000, Lane count = 4
...
<7> [1352.732720] [drm:intel_dp_start_link_train [i915]] [CONNECTOR:307:DP-3] Link Training failed at link rate = 810000, lane count = 4
...
<7> [1367.316904] [drm:intel_atomic_check [i915]] [CONNECTOR:307:DP-3] Limiting display bpp to 24 instead of EDID bpp 24, requested bpp 36, max platform bpp 36
<7> [1367.316963] [drm:intel_dp_compute_config [i915]] DP link computation with max lane count 4 max rate 540000 max bpp 24 pixel clock 967000KHz
<7> [1367.316994] [drm:intel_dp_compute_config [i915]] Force DSC en = 0
<7> [1367.317026] [drm:intel_atomic_check [i915]] Encoder config failure: -22
...
<3> [1367.318852] [drm:intel_display_resume [i915]] *ERROR* Restoring old state failed with -22

So the problem is that we originally picked 8.1 GHz link rate (which the mode requires due to the high dotclock, later on link training fails and we reduce the max link rate to 5.4GHZ which is not enough for the mode we already configured, and then the resume fails when it tries to restore it. Could result in a black screen after waking from suspend. In fact I suspect it will cause all displays to be black because the entire atomic commit across all pipes is declared as a failure.

Not sure if we should maybe just reset the max link params before resume...
Comment 4 Jani Saarinen 2019-11-06 18:32:11 UTC
Not seen on latest tgl runs (seen only once). Push this back to CI team and marking as resolved works for me. Please re-open if seen again.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.