Bug 11399 - screen completely garbled with ati open source driver when doing ctrl+alt+f1
Summary: screen completely garbled with ati open source driver when doing ctrl+alt+f1
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/Radeon (show other bugs)
Version: 7.2 (2007.02)
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: xf86-video-ati maintainers
QA Contact: Xorg Project Team
URL: https://bugs.launchpad.net/ubuntu/+so...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-06-28 00:01 UTC by Matteo Zandi
Modified: 2007-09-24 14:20 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
login screen with 6.6.193-1ubuntu1 (39.37 KB, image/jpeg)
2007-09-01 02:10 UTC, Matteo Zandi
no flags Details
X with 6.6.193-1ubuntu1 (59.10 KB, image/jpeg)
2007-09-01 02:11 UTC, Matteo Zandi
no flags Details
Garbled screen when resolution is 1280x800 (98.94 KB, image/jpeg)
2007-09-02 05:41 UTC, Matteo Zandi
no flags Details
xorg.conf currently using with ati 6.7.192-1ubuntu1 (2.51 KB, application/octet-stream)
2007-09-02 05:43 UTC, Matteo Zandi
no flags Details
Xorg.0.log with 6.7.192-1ubuntu1 (93.25 KB, text/plain)
2007-09-19 10:15 UTC, Matteo Zandi
no flags Details
xrandr --verbose with 6.7.192-1ubuntu1 (1.91 KB, text/plain)
2007-09-19 10:15 UTC, Matteo Zandi
no flags Details
Xorg.0.log with git master (128.37 KB, text/x-log)
2007-09-19 12:13 UTC, Matteo Zandi
no flags Details
xrandr --verbose with git master (2.01 KB, application/octet-stream)
2007-09-19 12:14 UTC, Matteo Zandi
no flags Details
Xorg.0.log with git 6.7.194 (78.32 KB, patch)
2007-09-24 14:14 UTC, Matteo Zandi
no flags Details | Splinter Review
xrandr --verbose with 6.7.194 (2.50 KB, patch)
2007-09-24 14:15 UTC, Matteo Zandi
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Matteo Zandi 2007-06-28 00:01:20 UTC
If I do a "ctrl+alt+f1" when X is running with the ati open source driver, the comp actually switch to consolle but the screen is totally garbled and it is impossible to read. This doesn't happen with fglrx driver, so that I'm able to switch between X and consolle and back with no problems.

See http://launchpadlibrarian.net/6675491/ati-X700-garbled.jpg
xorg.conf, http://launchpadlibrarian.net/6675496/xorg.conf
dmidecode, http://launchpadlibrarian.net/6988202/dmidecode
lspci -vv, http://launchpadlibrarian.net/6988205/lspci-vv

This garbled screen occours also shen shutting down the system, the text shown upon shutdown cannot be read.

I have this problem since breezy (Ubuntu 5.10), so I normally use the fglrx driver altough binary only. I have a ATI X700 video card and recent packages in feisty didn't solve this.

This bug has been manually forwarded from launchpad #90607
Comment 1 Alex Deucher 2007-08-31 08:58:10 UTC
This should be fixed.  Can you try the latest code from ati git or the ati 6.7.192 release?
Comment 2 Matteo Zandi 2007-09-01 02:03:37 UTC
using this version

$ dpkg -l | grep xserver-xorg-video-ati
ii  xserver-xorg-video-ati                     1:6.6.193-1ubuntu1           X.Org X server -- ATI display driver

switching to console and back works, but the screen is totally unusable when X is loaded (see pics).

I believe this garbled X was introduced by a specific patch

105_fdo_att7409_bug5437.diff

since if I leave out of compilation X works normally.

Now trying with 6.7.192
Comment 3 Matteo Zandi 2007-09-01 02:10:02 UTC
Created attachment 11371 [details]
login screen with 6.6.193-1ubuntu1
Comment 4 Matteo Zandi 2007-09-01 02:11:08 UTC
Created attachment 11372 [details]
X with 6.6.193-1ubuntu1
Comment 5 Matteo Zandi 2007-09-01 02:24:41 UTC
with 6.7.192-1ubuntu1 everything works!!!

still fonts are a bit blurred, I'll have a look at this issue and in case open a different bug.

Thank you very much!!
Comment 6 Matteo Zandi 2007-09-02 05:40:47 UTC
Now I understand why fonts are blurred: resolution is 1280x768 instead of 1280x800.

If I set it to 1280x800, screen is garbled (pic).

Reopening bug.
Comment 7 Matteo Zandi 2007-09-02 05:41:42 UTC
Created attachment 11383 [details]
Garbled screen when resolution is 1280x800
Comment 8 Matteo Zandi 2007-09-02 05:43:37 UTC
Created attachment 11384 [details]
xorg.conf currently using with ati 6.7.192-1ubuntu1
Comment 9 Alex Deucher 2007-09-13 18:01:56 UTC
Can you attach your log from the 6.7.x driver and the output of xrandr --verbose?
Comment 10 Matteo Zandi 2007-09-19 10:15:23 UTC
Created attachment 11635 [details]
Xorg.0.log with 6.7.192-1ubuntu1
Comment 11 Matteo Zandi 2007-09-19 10:15:54 UTC
Created attachment 11636 [details]
xrandr --verbose with 6.7.192-1ubuntu1
Comment 12 Alex Deucher 2007-09-19 11:01:50 UTC
Any chance you could try ati git master?
Comment 13 Matteo Zandi 2007-09-19 12:13:18 UTC
I built git master, but the problem is not solved. When I turn to 1280x800 I see the same garbled screen.

PS: I used "git-clone git://anongit.freedesktop.org/git/xorg/driver/xf86-video-ati"
Comment 14 Matteo Zandi 2007-09-19 12:13:56 UTC
Created attachment 11645 [details]
Xorg.0.log with git master
Comment 15 Matteo Zandi 2007-09-19 12:14:29 UTC
Created attachment 11646 [details]
xrandr --verbose with git master
Comment 16 Alex Deucher 2007-09-24 13:56:00 UTC
can you try again with ati git master or 6.7.194?
Comment 17 Matteo Zandi 2007-09-24 14:14:01 UTC
Created attachment 11733 [details] [review]
Xorg.0.log with git 6.7.194
Comment 18 Matteo Zandi 2007-09-24 14:15:08 UTC
Created attachment 11734 [details] [review]
xrandr --verbose with 6.7.194
Comment 19 Matteo Zandi 2007-09-24 14:16:03 UTC
with 6.7.194, 1280x800 works! thank you very much!


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.