Bug 11801 - Incorrect refresh rate with 9100 Pro IGP
Summary: Incorrect refresh rate with 9100 Pro IGP
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/Radeon (show other bugs)
Version: 7.2 (2007.02)
Hardware: x86 (IA32) All
: medium normal
Assignee: xf86-video-ati maintainers
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
: 13434 24423 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-08-01 16:20 UTC by Andreas Thienemann
Modified: 2010-10-19 15:50 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
xorg log running with the radeon driver. (45.20 KB, text/plain)
2007-08-01 16:22 UTC, Andreas Thienemann
no flags Details
xorg.conf file (834 bytes, application/octet-stream)
2007-08-01 16:23 UTC, Andreas Thienemann
no flags Details
Updated xorg log from newer ati drv (41.38 KB, text/plain)
2007-08-01 20:42 UTC, Andreas Thienemann
no flags Details
running with randr-1.2 branch (54.01 KB, text/plain)
2007-08-02 06:41 UTC, Andreas Thienemann
no flags Details
running x11 with the rawhide driver. (54.90 KB, text/plain)
2007-09-07 12:44 UTC, Andreas Thienemann
no flags Details
logfile with latest git checkout (55.59 KB, text/plain)
2007-10-06 14:27 UTC, Andreas Thienemann
no flags Details
running with rhgb - black screen (52.76 KB, text/plain)
2007-10-07 04:27 UTC, Andreas Thienemann
no flags Details
restarting the xserver - flickering screen (100.09 KB, text/plain)
2007-10-07 04:28 UTC, Andreas Thienemann
no flags Details
register dump running the radeon drive (14.71 KB, text/plain)
2008-06-10 16:14 UTC, Andreas Thienemann
no flags Details
register dump running the vesa driver (14.71 KB, text/plain)
2008-06-10 16:14 UTC, Andreas Thienemann
no flags Details
xorg log running xorg-x11-6.8.2-37.FC4.49.2.1 with ati-fglrx-8.26.18-1.lvn4 (52.19 KB, text/plain)
2009-04-03 10:55 UTC, Andreas Thienemann
no flags Details
register dump running the ati-fglrx driver. (18.11 KB, text/plain)
2009-04-03 10:56 UTC, Andreas Thienemann
no flags Details
Xorg.0.log from fedora rawhide running xorg-x11-drv-ati-6.12.2-2.fc11.i586 (101.41 KB, text/plain)
2009-04-18 06:22 UTC, Andreas Thienemann
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Thienemann 2007-08-01 16:20:09 UTC
Connecting a Samsung 930BF via DVI to an Asus Pundit R350 with a 9100 IGP results in the display being driven with incorrect modes.

The graphic card is detected as follows by lspci:

01:05.0 VGA compatible controller: ATI Technologies Inc Radeon 9100 PRO IGP

The attached TFT display should be used at 1280x1024 at about 60 kHz refresh rate.

The xorg.conf entry is accordingly set to have a Horizontal Sync of 31.5 - 67.0 kHz and a Vertical Refresh of 50.0 - 75.0 Hz.

When starting the xserver the display shows a message on the OSD saying:

"Not Optimum Mode
Recommended Mode: 
1280x1024 60Hz"

Taking a look at the OSD info screen shows the following:

Digital
32.2kHz 30Hz PP
1280x1024

It seems the radeon driver is being confused about the right way to drive the display.

Fiddling with the Horizontal and Vertical settings or defining a Target Refresh rate seem to have no affect.

Configuring the vesa driver instead results in a stable picture without flickering and wobbling. Only drawback is the resolution of 1024x786 with the vesa driver.
Comment 1 Andreas Thienemann 2007-08-01 16:22:50 UTC
Created attachment 10946 [details]
xorg log running with the radeon driver.
Comment 2 Andreas Thienemann 2007-08-01 16:23:59 UTC
Created attachment 10947 [details]
xorg.conf file
Comment 3 Alex Deucher 2007-08-01 19:34:13 UTC
Your setup uses an external TMDS controller which we currently don't have support for in the driver.  It may work with ati master or randr-1.2 from git if the bios sets up the external chip properly.
Comment 4 Andreas Thienemann 2007-08-01 20:41:43 UTC
(In reply to comment #3)
> Your setup uses an external TMDS controller which we currently don't have
> support for in the driver.

Crap. Currently means it's being developed?

> It may work with ati master or randr-1.2 from git if the bios sets up the 
> external chip properly.

Mhm, I just rebuilt the src.rpms from fedora with a current copy of xorg-driver-video-ati and libXrandr and installed these two. No visible change though.

Was that the correct process?
Comment 5 Andreas Thienemann 2007-08-01 20:42:14 UTC
Created attachment 10952 [details]
Updated xorg log from newer ati drv
Comment 6 Alex Deucher 2007-08-02 06:03:31 UTC
(In reply to comment #4)
> Crap. Currently means it's being developed?

well... I'd definitely like to get it supported, but we haven't had much luck as of yet.

> Mhm, I just rebuilt the src.rpms from fedora with a current copy of
> xorg-driver-video-ati and libXrandr and installed these two. No visible change
> though.
> 
> Was that the correct process?
> 

yes.  Try the randr-1.2 branch in git:
git clone git://anongit.freedesktop.org/git/xorg/driver/xf86-video-ati
cd xf86-video-ati
git checkout randr-1.2
or of you already have the git tree checked out:
git checkout randr-1.2

You'll need at least xserver 1.3
Comment 7 Andreas Thienemann 2007-08-02 06:35:11 UTC
(In reply to comment #6)
> well... I'd definitely like to get it supported, but we haven't had much luck
> as of yet.

:-(
 
> Try the randr-1.2 branch in git:
> git clone git://anongit.freedesktop.org/git/xorg/driver/xf86-video-ati
> cd xf86-video-ati
> git checkout randr-1.2
> or of you already have the git tree checked out:
> git checkout randr-1.2
> 
> You'll need at least xserver 1.3
Tried that, even though the local git wanted "origin/randr-1.2" as the branch-name.

According to the server log randr-1.2 was enabled but unfortunately no change yet on the screen.

However, I just noticed that analog works. At least I can work on the system now without headaches.
Comment 8 Alex Deucher 2007-08-02 06:41:18 UTC
(In reply to comment #7)

> > You'll need at least xserver 1.3
> Tried that, even though the local git wanted "origin/randr-1.2" as the
> branch-name.
> 

you must be using a newer version of git.

> According to the server log randr-1.2 was enabled but unfortunately no change
> yet on the screen.

the TMDS chip may require some additional setup are are not doing.

Comment 9 Andreas Thienemann 2007-08-02 06:41:20 UTC
Created attachment 10962 [details]
running with randr-1.2 branch
Comment 10 Dave Airlie 2007-08-05 18:05:27 UTC
can you get me a copy of your bios?

cd /sys/bus/pci/devices/<card_pci_id>
echo 1 > rom
cat rom /tmp/rom
echo 0 > rom

and send me the /tmp/rom at airlied@gmail.com?
Comment 11 Alex Deucher 2007-08-31 08:55:29 UTC
the randr-1.2 branch has been merged into ati master.  Any change with the latest code from ati git master?
Comment 12 Andreas Thienemann 2007-09-07 12:43:21 UTC
(In reply to comment #11)

> the randr-1.2 branch has been merged into ati master.  Any change with the
> latest code from ati git master?

I could not yet try git master.

According to ajax however rawhide is shipping the randr-1.2 branch which I tried earlier with the following versions:

(II) Loading /usr/lib/xorg/modules/drivers//radeon_drv.so
(II) Module radeon: vendor="X.Org Foundation"
        compiled for 1.3.0, module version = 4.3.0
        Module class: X.Org Video Driver
        ABI class: X.Org Video Driver, version 1.2
(II) LoadModule: "ati"
(II) Loading /usr/lib/xorg/modules/drivers//ati_drv.so
(II) Module ati: vendor="X.Org Foundation"
        compiled for 1.3.0, module version = 6.7.192
        Module class: X.Org Video Driver
        ABI class: X.Org Video Driver, version 1.2


There has been some change in fact: The screen is not showing the jittery image anymore from before but is simply black with the no signal message flashing.
Comment 13 Andreas Thienemann 2007-09-07 12:44:30 UTC
Created attachment 11464 [details]
running x11 with the rawhide driver.
Comment 14 Alex Deucher 2007-09-22 13:26:26 UTC
This should be fixed in ati git master.
Comment 15 Andreas Thienemann 2007-10-06 14:24:20 UTC
(In reply to comment #14)

> This should be fixed in ati git master.

Okay, I finally got around to checking out the newest git tree and applied it on the testbox.

Unfortunately, the problem is still the same.
Comment 16 Andreas Thienemann 2007-10-06 14:27:41 UTC
Created attachment 11920 [details]
logfile with latest git checkout
Comment 17 Alex Deucher 2007-10-06 15:14:43 UTC
looks like your bios connector table is wrong.  try adding this option to your config:

Option "ConnectorTable" "3,2,1,4,4,1,2,2"
Comment 18 Andreas Thienemann 2007-10-07 04:26:34 UTC
(In reply to comment #17)

> looks like your bios connector table is wrong.  try adding this option to your
> config:
> 
> Option "ConnectorTable" "3,2,1,4,4,1,2,2"

No real luck. Doesn't change a thing.
Interestingly, when booting with rhgb, the graphical boot overlay, the DVI screen stays black and the normal x-server in runlevel 5 won't show on the attached display.
Restarting it by giving the Zap-command on the keyboard however sucessfully starts the xserver with the same flickering display as before.
Comment 19 Andreas Thienemann 2007-10-07 04:27:21 UTC
Created attachment 11926 [details]
running with rhgb - black screen
Comment 20 Andreas Thienemann 2007-10-07 04:28:23 UTC
Created attachment 11927 [details]
restarting the xserver - flickering screen
Comment 21 Alex Deucher 2007-10-07 08:07:27 UTC
the IGP chips must need some special setting for FP2.  can you provide dumps with radeontool (http://cgit.freedesktop.org/~airlied/radeontool/) for vesa and the current radeon driver?

once X is started run (as root):
radeontool regmatch '*'
Comment 22 Andreas Thienemann 2007-10-07 11:15:17 UTC
(In reply to comment #21)

> once X is started run (as root):
> radeontool regmatch '*'

Mhm, this seems somewhat unsupported:


[root@dyn100 radeontool]# ./radeontool --help
usage: radeontool [options] [command]
         --debug            - show a little debug info
         --skip=1           - use the second radeon card
         dac [on|off]       - power down the external video outputs (on)
         light [on|off]     - power down the backlight (off)
         stretch [on|off|vert|horiz|auto|manual]   - stretching for resolution mismatch 
         regs               - show a listing of some random registers
         regmatch <pattern> - show registers matching wildcard pattern
         regset <pattern> <value> - set registers matching wildcard pattern
[root@dyn100 radeontool]# 

Comment 23 Alex Deucher 2007-10-07 12:25:03 UTC
(In reply to comment #22)
> (In reply to comment #21)
> 
> > once X is started run (as root):
> > radeontool regmatch '*'
> 
> Mhm, this seems somewhat unsupported:
> 
> 
> [root@dyn100 radeontool]# ./radeontool --help
> usage: radeontool [options] [command]
>          --debug            - show a little debug info
>          --skip=1           - use the second radeon card
>          dac [on|off]       - power down the external video outputs (on)
>          light [on|off]     - power down the backlight (off)
>          stretch [on|off|vert|horiz|auto|manual]   - stretching for resolution
> mismatch 
>          regs               - show a listing of some random registers
>          regmatch <pattern> - show registers matching wildcard pattern

           ^^^^^^^^  regmatch '*'

you want to match all regs.
Comment 24 Andreas Thienemann 2008-06-10 16:12:18 UTC
(In reply to comment #21)
> the IGP chips must need some special setting for FP2.  can you provide dumps
> with radeontool (http://cgit.freedesktop.org/~airlied/radeontool/) for vesa and
> the current radeon driver?
> 
> once X is started run (as root):
> radeontool regmatch '*'
> 

Sorry for the long delay, the hardware was unfortunately absent.

I managed to get the register dumps from the 9100 IGP running on fedora 9 now.
One is running the radeon driver, the other the vesa driver with a lower resolution.

Comment 25 Andreas Thienemann 2008-06-10 16:14:13 UTC
Created attachment 17040 [details]
register dump running the radeon drive
Comment 26 Andreas Thienemann 2008-06-10 16:14:46 UTC
Created attachment 17041 [details]
register dump running the vesa driver
Comment 27 Andreas Thienemann 2009-04-03 10:55:59 UTC
Created attachment 24509 [details]
xorg log running xorg-x11-6.8.2-37.FC4.49.2.1 with ati-fglrx-8.26.18-1.lvn4

This is a Xorg logfile from Fedora Core 4 with xorg-x11-6.8.2-37.FC4.49.2.1 running the ati-fglrx-8.26.18-1.lvn4 closed source driver.

DVI Output is working correctly with this setup.
Comment 28 Andreas Thienemann 2009-04-03 10:56:57 UTC
Created attachment 24510 [details]
register dump running the ati-fglrx driver.

This is a radeontool regmatch dump from Fedora Core 4 with xorg-x11-6.8.2-37.FC4.49.2.1 running the ati-fglrx-8.26.18-1.lvn4 closed source driver.

DVI Output is working correctly with this setup.
Comment 29 Andreas Thienemann 2009-04-18 06:22:36 UTC
Created attachment 24917 [details]
Xorg.0.log from fedora rawhide running xorg-x11-drv-ati-6.12.2-2.fc11.i586

As suggested by adamw, a current Xorg log from rawhide.
Comment 30 Alex Deucher 2009-10-19 07:08:45 UTC
*** Bug 13434 has been marked as a duplicate of this bug. ***
Comment 31 Alex Deucher 2009-10-19 07:10:18 UTC
*** Bug 24423 has been marked as a duplicate of this bug. ***
Comment 32 Alex Deucher 2009-11-10 15:50:53 UTC
Can someone attach their video bios?  See instructions in comment 10?
Comment 33 Alex Deucher 2009-11-11 08:12:55 UTC
I've implemented support for external TMDS on IGP chips in kms.  You can grab the patches here:
http://marc.info/?l=dri-devel&m=125790709403851&w=2
If I have time, I'll add support for UMS as well.
Comment 34 Alex Deucher 2009-11-11 10:15:09 UTC
Just pushed the fix to the ddx as well:
2af2744c80f3307e6d84edba9479be5bd36e1d03


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.