Bug 12244 - "Key not found" when using the email interface
Summary: "Key not found" when using the email interface
Status: RESOLVED NOTABUG
Alias: None
Product: freedesktop.org
Classification: Unclassified
Component: Account Modification Requests (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: fd.o Admin Massive
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-09-01 01:51 UTC by Pekka Paalanen
Modified: 2008-01-12 04:37 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Description Pekka Paalanen 2007-09-01 01:51:37 UTC
I get the following whenever I try to update my SSH keys or get my
account details with the "show" command.
( http://www.freedesktop.org/wiki/AccountMaintenance )

On Fri, 31 Aug 2007 21:21:13 +0000
admin@db.freedesktop.org wrote:

> Hello!
> 
> Your request to the mail gateway is malformed, or an internal
> processing error occured. The information below may help you, or the
> gateway administrator to identify the problem.
> 
> Error: An error occured while performing the LDAP lookup  
> ==> Message Error: Key not found  
> 
> 
> Please email admin@db.freedesktop.org if you have any questions.
>   

My account was created as per bug #11487 and I checked that I attached
the correct GPG key there. I also checked that I can find my key via subkeys.pgp.net.

Does it look like my GPG key missing from fd.o or am I signing my email somehow with a different key? AFAICT I have only one key I can sign with, but I'm not that familiar with GPG.
Comment 1 Pekka Paalanen 2007-09-01 01:54:35 UTC
Oh yeah, my username is 'pq'.
Comment 2 Pekka Paalanen 2007-09-17 12:08:09 UTC
I have tried the "show" command using PGP MIME signature on 29th Aug, 31st Aug, 1st Sep, 5th Sep, 9th Sep, 12th Sep and 17th Sep, every time with the above described result.

Should I just ask some admin to update my SSH keys for me, or file a bug with the new set of SSH keys?
Comment 3 Pekka Paalanen 2007-10-07 12:28:14 UTC
Um, guys?

Could someone reset my GPG key to what I submitted in bug #11487?
Or should I do something?

I tried just now, and still "key not found".
Comment 4 Pekka Paalanen 2007-10-07 13:57:15 UTC
Ok, the problem is on my part. I have more than the one default DSA+ElGamal key, and gpg insists on using the latest DSA key for signing messages. Daniels says I should use the ElGamal key.

Unfortunately, I cannot force gpg to use any other subkey than the latest DSA key.
Maybe I can figure out how to do that some day...
Comment 5 Pekka Paalanen 2007-10-07 14:29:31 UTC
Alright, I got it working. Kind of.

I made a backup of my .gnupg/ directory. Deleted the new key pair (DSA+whatever), so that only the original DSA+ElGamal key pair is left. I call this configuration as .gnupg-old. The backed up version is .gnupg-new.

Using .gnupg-old I can send a message and it gets processed properly. To read the answer I have to use .gnupg-new, because the reply is encrypted with the new deleted subkey.

So, I send a message using one subkey (pair), and the reply is encrypted with another subkey (pair). Trying to send a message with the new subkey (pair) results in the previously mentioned "key not found".

Would it be possible for the reply to be encrypted with the *same* subkey pair as the original message?
Maybe that is a problem one magnitude bigger than my problem of getting the right subkey used in signing, which I still do not know how to do.
Comment 6 Benjamin Close 2007-11-19 20:53:43 UTC
In gpg, I thought you could set the subkey you wanted as default using:

gpg --edit-key YOURKEY
key x    (where x is the key you want)
primary
save

Or have I been out the gpg game too long?
Comment 7 Stéphane Loeuillet 2007-11-20 01:38:45 UTC
Akaik, primary is to set the default uid/identity. Not the default subkey
Comment 8 Benjamin Close 2007-12-10 05:39:27 UTC
http://fortytwo.ch/gpg/subkeys

Seems to indicate you can use the "keyid!" syntax to choose a gpg subkey. Ie the ! is important.. though I've not been able to find any other details about it.

Perhaps you could trial a few attempts and see if you can get something working.
Comment 9 Benjamin Close 2008-01-11 02:39:00 UTC
Bugzilla Upgrade Mass Bug Change

NEEDSINFO state was removed in Bugzilla 3.x, reopening any bugs previously listed as NEEDSINFO.

  - benjsc
    fd.o Wrangler
Comment 10 Benjamin Close 2008-01-11 05:51:44 UTC
Howdy, have you had a chance to try this subkey? thingy?
Comment 11 Pekka Paalanen 2008-01-12 04:37:15 UTC
I tried it now, and the exclamation mark after subkey id really makes the difference. I am able to use the right subkey for signing my "show" request, and I am able to decrypt the reply in sylpheed-claws.

I guess we can close this as not-a-bug.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.