Bug 12571 - Screen displays garbage with DRI on 9250
Summary: Screen displays garbage with DRI on 9250
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/Radeon (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: xf86-video-ati maintainers
QA Contact: Xorg Project Team
URL: https://bugs.launchpad.net/ubuntu/+so...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-09-26 00:10 UTC by Timo Aaltonen
Modified: 2010-10-19 21:33 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Timo Aaltonen 2007-09-26 00:10:29 UTC
Forwarded from https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/133192

2007-08-17
Since the updates a few days ago on gutsy, my screen only shows garbage with only the mouse pointer shown normally. This is on a radeon 9250.

(the version which was uploaded mid-August is 6.6.193)
Comment 1 Timo Aaltonen 2007-09-26 00:13:11 UTC
disabling glx makes the problem to go away.
Comment 3 Timo Aaltonen 2007-09-26 00:30:53 UTC
6.7.194 is still broken for him.. logs are coming.
Comment 4 Michel Dänzer 2007-09-26 00:41:34 UTC
(In reply to comment #1)
> disabling glx makes the problem to go away.

More likely what matters is the DRI, which is also disabled implicitly when GLX is disabled.

AFAICT nobody actually tried with tiling disabled - the option name is "ColorTiling".
Comment 5 Timo Aaltonen 2007-09-26 01:32:37 UTC
Ok, I'll ask that.

Here is the log with glx enabled:

http://launchpadlibrarian.net/9512620/Xorg.0.log
Comment 6 Timo Aaltonen 2007-09-26 01:44:43 UTC
on trying ColorTiling:

"Tried that, doesn't help. Also tried only disabling DRI as mentioned in the upstream report, but that doesn't do anything either. Only disabling glx works."
Comment 7 Michel Dänzer 2007-09-26 01:56:46 UTC
(In reply to comment #6)
> on trying ColorTiling: [...]

Saw that... again, the option name was spelt incorrectly in the downstream bug report, and the log file shows it misspelt in the same way and thus ineffective.
Comment 8 Timo Aaltonen 2007-09-29 03:03:20 UTC
Disabling dri is the only thing which made it work:

http://launchpadlibrarian.net/9522639/Xorg.0.nodri2.log

Comment 9 Timo Aaltonen 2008-01-11 15:30:32 UTC
This bug is actually about the AGPMode mess that's going on :) Setting it to "4" works for the reporter.
Comment 10 Michel Dänzer 2008-01-12 04:07:29 UTC
Unfortunately, as far as we can tell it's just impossible to always pick a default value for AGPMode that works, and in general leaving it unchanged from what the BIOS set up seems most reliable. I'm afraid it looks like the cases where that doesn't work need to change it in the BIOS setup or xorg.conf.
Comment 11 Tormod Volden 2008-01-12 09:14:41 UTC
If I understand the current code correctly, the default is to leave it unchanged for v3 cards, but to use x1 for v2 cards. This breaks for some v2 cards. I think the old behaviour of leaving v2 cards unchanged also broke on some cards.
Comment 12 Michel Dänzer 2008-01-12 09:18:53 UTC
Sure, this bug is about V3 though, but the same problem also occurred when we defaulted to 4x for that. Right now it's looking like leaving it unchanged is most reliable overall, and we should probably switch back to that for non-V3 as well.
Comment 13 Alex Deucher 2008-12-03 00:21:54 UTC
if this is still an issue with the driver from git, we can add a quirk for your card/gpu combo.
Comment 14 Alex Deucher 2010-10-19 15:53:10 UTC
closing due to lack of feedback.
Comment 15 Timo Aaltonen 2010-10-19 21:33:52 UTC
it was apparently fixed already with a quirk, sorry for not closing this earlier :)


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.