Bug 12655 - evdev mouse error: Cannot open input pEvdev
evdev mouse error: Cannot open input pEvdev
Status: RESOLVED FIXED
Product: xorg
Classification: Unclassified
Component: Input/evdev
7.3 (2007.09)
Other All
: medium normal
Assigned To: Zephaniah E. Hull
Xorg Project Team
:
: 6985 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-02 14:31 UTC by Jan Merka
Modified: 2008-04-07 17:19 UTC (History)
4 users (show)

See Also:


Attachments
Updated documentation for xf86-input-evdev>=1.2.0 (6.61 KB, text/plain)
2008-02-20 11:21 UTC, Sascha Hlusiak
no flags Details
diff evdev.man.old evdev.man (10.03 KB, patch)
2008-02-28 05:44 UTC, Sascha Hlusiak
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Merka 2007-10-02 14:31:26 UTC
The xf86-input-evdev driver version 1.2.0 (from git, no source package available) does not work with xorg server 1.4. The log file shows:

(**) Mouse0: Buttons: 9
(**) Mouse0: Sensitivity: 1
(**) Option "SendCoreEvents"
(**) Logitech_VX: always reports core events
(EE) Logitech_VX: cannot open input pEvdev
(II) UnloadModule: "evdev"
(EE) PreInit returned NULL for "Logitech_VX"
(**) Option "CoreKeyboard"

The error message comes evidently from evdev.c but I don't understand what is wrong. The mouse is configured as

Section "InputDevice"
        Identifier      "Logitech_VX"
        Driver          "evdev"
        Option          "SendCoreEvents"
        Option  "Name"  "Logitech USB Receiver"
        Option  "Phys"  "usb-*/input0"
        Option  "HWHEELRelativeAxisButtons" "7 6"
EndSection

This mouse configuration used to work for X11R7.2 (xf86-input-evdev 1.1.2) so it seems like the latest server and driver introduced some incompatibility.

Jan
Comment 1 Zephaniah E. Hull 2007-11-14 15:41:29 UTC
User (and documentation) error.

Quite simply, you need a completely different X config for xf86-input-evdev 1.2.x.

For hotplugging, you need to use the server's hotplug stuff.

We should however fix the documentation.
Comment 2 Timo Aaltonen 2008-02-06 23:20:08 UTC
When will the documentation be fixed? Users are getting frustrated, reporting bugs about it all the time...
Comment 3 Peter Hutterer 2008-02-07 23:26:10 UTC
(In reply to comment #2)
> When will the documentation be fixed? Users are getting frustrated, reporting
> bugs about it all the time...
> 

Timo: Please feel free to send patches to update the man pages and other documentation. 

IIRC, the problem is simply that only option "Device" is upported, not "Name" and/or "Phys".
not sure about the hweel... option though.
Comment 4 Sascha Hlusiak 2008-02-20 08:41:15 UTC
*** Bug 6985 has been marked as a duplicate of this bug. ***
Comment 5 Sascha Hlusiak 2008-02-20 11:21:47 UTC
Created attachment 14459 [details]
Updated documentation for xf86-input-evdev>=1.2.0

Please review attached updated man page, which reflects the current state of the driver. Not all options are well documented, but at least they are mentioned and invalid stuff was removed.

If you are happy with it, I'll commit it upstream.
Comment 6 ajax at nwnk dot net 2008-02-24 18:23:54 UTC
Mass reopen.  The "REMIND" resolution is lame, I'm deleting it.  Consider yourself reminded.
Comment 7 Peter Hutterer 2008-02-25 00:24:52 UTC
(In reply to comment #5)
> Please review attached updated man page, which reflects the current state of
> the driver. Not all options are well documented, but at least they are
> mentioned and invalid stuff was removed.

can you please upload a diff? this way it's a bit hard to figure out what changed.
but from looking at it it looks good. does the Path option still work?
Comment 8 Sascha Hlusiak 2008-02-28 05:44:59 UTC
Created attachment 14643 [details] [review]
diff evdev.man.old evdev.man

Attached the diff that updates the man page to reflect current state of source code.

By looking at the source code, the Path option is still supported and the Device option is used as a fallback.
Comment 9 Peter Hutterer 2008-03-01 19:41:09 UTC
(In reply to comment #8)
> Created an attachment (id=14643) [details]
> diff evdev.man.old evdev.man
>

ACK.
Comment 10 Sascha Hlusiak 2008-03-04 08:14:46 UTC
(In reply to comment #9)
> (In reply to comment #8)
> > Created an attachment (id=14643) [details] [details]
> > diff evdev.man.old evdev.man
> >
> ACK.
> 
Pushed. Feel free to close this bug.