Bug 12692 - xf86-video-radeonhd won't compile on 64-bit platform, stdint.h conflict
Summary: xf86-video-radeonhd won't compile on 64-bit platform, stdint.h conflict
Status: RESOLVED WONTFIX
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/radeonhd (show other bugs)
Version: git
Hardware: x86-64 (AMD64) FreeBSD
: medium major
Assignee: Egbert Eich
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
: 12693 12694 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-10-05 09:31 UTC by Coleman Kane
Modified: 2007-11-28 04:30 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
This fixes some of the stdint.h overlaps. (525 bytes, patch)
2007-10-06 13:50 UTC, Coleman Kane
no flags Details | Splinter Review

Description Coleman Kane 2007-10-05 09:31:37 UTC
The current xf86-video-radeonhd driver won't build on 64-bit platforms due to attempts to override stdint types in src/AtomBios/includes/CD_Common_Types.h.

Need to add CPP macros to not redefine these in the event that HAVE_STDINT_H is defined.
Comment 1 Matt Kraai 2007-10-06 00:44:30 UTC
*** Bug 12693 has been marked as a duplicate of this bug. ***
Comment 2 Matt Kraai 2007-10-06 08:17:08 UTC
*** Bug 12694 has been marked as a duplicate of this bug. ***
Comment 3 Coleman Kane 2007-10-06 13:50:22 UTC
Created attachment 11919 [details] [review]
This fixes some of the stdint.h overlaps.

This should get the thing to build.
Comment 4 Coleman Kane 2007-10-06 13:52:38 UTC
When I created this issue, bugzilla puked an error to the screen, indicating the non existence of Mail::Parse perl module (or something along those lines). I re-submitted with the same error resulting...

It looks like the bug did get registered, and the duplicate did too. I sent the message off to the email address it told me to send it to, but I haven't gotten a response back. Anyway, that is the reason for the annoying dupe.
Comment 5 Egbert Eich 2007-10-24 13:02:11 UTC
FreeBSD support has been added with 6e09935265a8fd2724b2f0986c087ff77d26e810
on 10/18/2007. Could you please check?
I will see if the patch you provided works better actually.
Comment 6 Coleman Kane 2007-10-24 13:25:20 UTC
(In reply to comment #5)
> FreeBSD support has been added with 6e09935265a8fd2724b2f0986c087ff77d26e810
> on 10/18/2007. Could you please check?
> I will see if the patch you provided works better actually.
> 

I just tested compilation and install of the v0.0.2 port on FreeBSD/amd64 8-CURRENT. It compiled fine. I don't have an actual RadeonHD card to test against though for functionality.
Comment 7 Egbert Eich 2007-10-25 10:44:45 UTC
Accepting this ticket.
Comment 8 Luc Verhaegen 2007-11-19 10:42:39 UTC
Wasn't this fixed already?
Comment 9 Coleman Kane 2007-11-19 10:50:42 UTC
(In reply to comment #8)
> Wasn't this fixed already?
> 

Yes, this was fixed. I think the latest version in ports has the proper fixes in it too. The response in comment #6 was after my testing of the new updates.

I have to track the HEAD now for different reasons... but this ticket should get closed methinks.
Comment 10 Egbert Eich 2007-11-26 02:02:23 UTC
The solution proposed here is more generic - therefore I wanted to try this.
This was the reason why I kept this report open.
Comment 11 Egbert Eich 2007-11-28 04:30:54 UTC
The proposed patch in attchment #11919 requires the inclusion of stdint.h. This would have to be added to the atombios parser code, too. We don't want to do this as we want to change ATI supplied code as little as possible ATM to stay in sync with the upstream version.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.