Bug 128 - libX11 has locale-handling issues
Summary: libX11 has locale-handling issues
Status: CLOSED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Lib/Xlib (show other bugs)
Version: unspecified
Hardware: x86 (IA32) FreeBSD
: high normal
Assignee: Eric Anholt
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-10-29 00:06 UTC by Eric Anholt
Modified: 2011-10-15 17:23 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
patch to respect prefix, install more libX11 required files (3.27 KB, patch)
2003-10-31 15:04 UTC, Eric Anholt
no flags Details | Splinter Review

Description Eric Anholt 2003-10-29 00:06:40 UTC
Starting xterm (or other X11 apps, with similar errors) on a FreeBSD system with
libX11 installed produces:

Warning: locale not supported by Xlib, locale set to C
Warning: X locale modifiers not supported, using default
Failed to open input method

XFree86's libX11 doesn't produce any error output.  Other than that it appears
to be working.  I'm guessing this is what's causing my editor, SciTE, to not
have its window title appear.  This doesn't appear to be related to the failure
to define CSRG_BASED or MALLOC_0_RETURNS_NULL on FreeBSD as the XFree86 build did.
Comment 1 Jim Gettys 2003-10-29 10:09:24 UTC
I can't reproduce this problem on Linux; I'm quite sure when I
run xterm here I'm using the one I built.

The I18N stuff is quite baroque: it is probably not able to load the right
stuff (I think it uses a set of shared libraries).  Maybe we aren't doing
"the right thing" with libtool.
Comment 2 Eric Anholt 2003-10-31 15:04:54 UTC
Created attachment 66 [details] [review]
patch to respect prefix, install more libX11 required files

I noticed that several things in libX11 were looking for files, including
locale files, under /usr/lib instead of ${PREFIX}/share/X11.  Also, some files
(XErrorDB, Xcms.txt) weren't being installed, though they were being looked
for.

The locale problem was that my locale files installed by XFree86 are in
${PREFIX}/lib/X11/locale.  Should libX11 be installing locale files itself, or
should we have a locale file package, or what?	As it is, I'm having my libX11
package make a link from ${PREFIX}/lib/X11/locale to
${PREFIX}/share/X11/locale.
This has got the issues reported in this bug fixed for me.
Comment 3 Eric Anholt 2003-10-31 15:06:07 UTC
Produced a patch, waiting for feedback.  Assign to myself.
Comment 4 Eric Anholt 2003-10-31 16:37:32 UTC
Comment on attachment 66 [details] [review]
patch to respect prefix, install more libX11 required files

Patch was committed but without the installation of Xcms.txt, which keithp
recommended not be done.  Bug will be left open due to the fact that we still
don't have a package for the locale files.  I'll try to work on this.
Comment 5 Jim Gettys 2003-10-31 18:32:20 UTC
Seems sensible...
Comment 6 Jim Gettys 2003-11-02 07:18:16 UTC
Unfortunately, it isn't working...  At least on Linux...

[jg@laptop xlibs]$ acroread
Warning: locale not supported by Xlib, locale set to C
Warning: X locale modifiers not supported, using default
Fatal System Error: Raise at top of Exception Stack
Aborted

Seems like we need to try this again...

                          - Jim
Comment 7 Eric Anholt 2003-11-02 13:21:54 UTC
That's the "we still don't have a package for the locale files" part.  It's now
looking in the correct location rather than an arbitrary one where XFree86
happens to install the locale files on Linux.  For now you can work around it
with a symlink to your XFree86-installed locale files.  I'll be working on a
package of the locale files which will be separate from libX11 (as agreed on in
IRC).  However, if nothing but libX11 uses the locale files directly, it might
make sense to have them be part of the libX11 package.
Comment 8 Warren Turkal 2004-01-11 04:32:41 UTC
I believe this bug is closed. I did much work to get everything in place
correctly a couple weeks ago. I just got a bugzilla account. I am closing this
bug because I do not think it is relevant anymore. If there is still a problem,
please reopen it.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.