Bug 12922 - XAA broken with current xorg from git (drm modules+intel driver)
Summary: XAA broken with current xorg from git (drm modules+intel driver)
Status: RESOLVED WONTFIX
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/other (show other bugs)
Version: DRI git
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-10-25 05:41 UTC by Jens Stroebel
Modified: 2009-02-05 00:29 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
xorg.conf showing XAA broken-ness on intel 945GM+965GM (3.77 KB, text/plain)
2007-10-25 05:44 UTC, Jens Stroebel
no flags Details
xorg hang log (20.96 KB, application/octet-stream)
2008-03-17 05:16 UTC, Vedran Rodic
no flags Details
xorg crashing with XAA on 965GM (27.86 KB, text/plain)
2008-04-09 03:31 UTC, Jens Stroebel
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jens Stroebel 2007-10-25 05:41:19 UTC
when using 
xorg-libs, xorg-server, xorg-driver, Mesa, drm, pixman (all from git 2007-10-24)
on either intel 945GM or 965GM, the display is unusable;
on 965GM the screen is mainly dark (black) and the shapes of the windows which should be present are visible;
on 945GM the screen is completely distorted to unusability.
Comment 1 Jens Stroebel 2007-10-25 05:44:21 UTC
Created attachment 12184 [details]
xorg.conf showing XAA broken-ness on intel 945GM+965GM
Comment 2 Jens Stroebel 2007-12-13 07:08:02 UTC
I cannot reproduce the described behavior anymore, using all components from current git.
Comment 3 Jens Stroebel 2007-12-13 07:24:11 UTC
The described brokenness only occurs with drm kernel modules from git.
Comment 4 Jens Stroebel 2007-12-13 07:26:38 UTC
(In reply to comment #3)
> The described brokenness only occurs with drm kernel modules from git.

additional info:

linux kernel 2.6.23.9
all parts of xorg (xserver, libs, drivers, drm, mesa) from current git 2007-12-13

chip 965GM on Dell latitude D830

Comment 5 Michael Fu 2008-01-03 21:40:52 UTC
resolve this bug according to comment# 2...
Comment 6 Jens Stroebel 2008-02-13 04:49:19 UTC
With all xorg components from git (2008-02-12), linux kernel 2.6.23.16 and drm modules from git,  XAA is again unusable.
(kdm login screen stays black except the username and password fields; after login, splash does not get removed when his time is over. Opened terminals, regardsless if it's xterm or konsole, are just frames showing the underlying desktop in their working area. Entering commands shows only those parts of the output which is colored differently than normal [e.g. executable files in a colored ls]).
Comment 7 Jens Stroebel 2008-03-04 06:37:19 UTC
still present with git versions from today (2008-03-04) as described in the previous comment.

minor changes:

kernel now linux 2.6.23.17 and unable to test on 945GM because hardware is currently not present.
Comment 8 Jens Stroebel 2008-03-04 06:47:05 UTC
(In reply to comment #7)
> kernel now linux 2.6.23.17 and unable to test on 945GM because hardware is
> currently not present.

wupps.. 1 major change: 

starting the kde session instantly crashes X and leaves only blackness, including the consoles (no VT switching visible)

gdb backtrace:
 

#0  0xb7fb668f in DRIUnlock (pScreen=0x8270f00) at dri.c:2202
#1  0xb7a53ac6 in I830WaitLpRing () from /opt/Xorg/lib/xorg/modules/drivers//intel_drv.so
#2  0xb7a53d78 in I830Sync () from /opt/Xorg/lib/xorg/modules/drivers//intel_drv.so
#3  0xb7890c19 in XAALeaveVT (index=0, flags=0) at xaaInit.c:522
#4  0x080ed457 in xf86XVLeaveVT (index=0, flags=0) at xf86xv.c:1268
#5  0xb7b46314 in glxDRILeaveVT (index=0, flags=0) at glxdri.c:891
#6  0x080b5aed in AbortDDX () at xf86Init.c:1302
#7  0x08163276 in AbortServer () at log.c:406
#8  0x08163603 in FatalError (f=0xb7a982a4 "lockup\n") at log.c:552
#9  0xb7a53b06 in I830WaitLpRing () from /opt/Xorg/lib/xorg/modules/drivers//intel_drv.so
#10 0xb7a53d78 in I830Sync () from /opt/Xorg/lib/xorg/modules/drivers//intel_drv.so
#11 0xb7896d0b in XAAPolySegmentFallback (pDraw=0x862ecd0, pGC=0x86320e0, nseg=1,
    pSeg=0x869ca8c) at xaaFallback.c:151
#12 0xb78e3edb in cwPolySegment (pDst=0x862ecd0, pGC=0x86320e0, nseg=1, pSegs=0x869ca8c)
    at cw_ops.c:284
#13 0x081afb01 in damagePolySegment (pDrawable=0x862ecd0, pGC=0x86320e0, nSeg=1,
    pSeg=0x869ca8c) at damage.c:1072
#14 0x080873f6 in ProcPolySegment (client=0x85e2b98) at dispatch.c:1705
#15 0x08083e6d in Dispatch () at dispatch.c:454
#16 0x0806b75b in main (argc=5, argv=0xbfaf9244, envp=0xbfaf925c) at main.c:441
Comment 9 Vedran Rodic 2008-03-17 05:15:58 UTC
I get a similar problem, but the difference is that on my computer X hangs immediately. xorg log attached (the console buffer i managed to salvage).




Comment 10 Vedran Rodic 2008-03-17 05:16:18 UTC
Created attachment 15224 [details]
xorg hang log
Comment 11 Jens Stroebel 2008-04-09 03:30:06 UTC
with all parts of xorg from current git (2008-04-09), kernel 2.6.23.17 and on intel 965GM, xorg now crashes when using XAA acceleration.

backtrace:

#############################################
#0  0xb7fae68f in DRIUnlock (pScreen=0x82756e0) at dri.c:2202
#1  0xb7a44fde in I830WaitLpRing () from /opt/Xorg/lib/xorg/modules/drivers//intel_drv.so
#2  0xb7a453ee in I830Sync () from /opt/Xorg/lib/xorg/modules/drivers//intel_drv.so
#3  0xb7880c19 in XAALeaveVT (index=0, flags=0) at xaaInit.c:522
#4  0x080e16f3 in xf86XVLeaveVT (index=0, flags=0) at xf86xv.c:1268
#5  0xb7b4426b in glxDRILeaveVT (index=0, flags=0) at glxdri.c:889
#6  0x080b5f59 in AbortDDX () at xf86Init.c:1302
#7  0x0816432a in AbortServer () at log.c:406
#8  0x081646b7 in FatalError (f=0xb7a998e0 "lockup\n") at log.c:552
#9  0xb7a4501e in I830WaitLpRing () from /opt/Xorg/lib/xorg/modules/drivers//intel_drv.so
#10 0xb7a453ee in I830Sync () from /opt/Xorg/lib/xorg/modules/drivers//intel_drv.so
#11 0xb7886dbb in XAAPolySegmentFallback (pDraw=0x8634388, pGC=0x86a5530, nseg=1,
    pSeg=0x86a2240) at xaaFallback.c:151
#12 0xb78d3f8b in cwPolySegment (pDst=0x8634388, pGC=0x86a5530, nseg=1, pSegs=0x86a2240)
    at cw_ops.c:284
#13 0x081b0d89 in damagePolySegment (pDrawable=0x8634388, pGC=0x86a5530, nSeg=1,
    pSeg=0x86a2240) at damage.c:1072
#14 0x08087886 in ProcPolySegment (client=0x87186c8) at dispatch.c:1705
#15 0x080842fd in Dispatch () at dispatch.c:454
#16 0x0806bbea in main (argc=5, argv=0xbfe7e974, envp=0xbfe7e98c) at main.c:455
#############################################

attaching Xorg.log ...
Comment 12 Jens Stroebel 2008-04-09 03:31:44 UTC
Created attachment 15779 [details]
xorg crashing with XAA on 965GM

all xorg git from 2008-04-09, Mesa git from 2008-04-09,
Comment 13 Jens Stroebel 2008-04-17 08:25:32 UTC
I finally found the time to bisect this; don't know why the first report I gave misleadingly pointed to 2007-10-24 but bisection resulted in

#################################################################
commit 11f3e5e53f8fc4de90d1c289e0ba218ddfca23dc
Author: Thomas Hellstrom <thomas-at-tungstengraphics-dot-com>
Date:   Thu Oct 25 10:12:21 2007 +0200

    Buffer manager:
    Implement a version check IOCTL for drivers that don't use
    drmMMInit from user-space.
    Remove the minor check from the kernel code. That's really up
    to the driver.
    Bump major.
#################################################################

I re-checked by taking drm-modules without this commit and then with it, and it is indeed the one that causes the XAA broken-ness with intel driver and intel 965GM.
Comment 14 Gordon Jin 2009-02-05 00:29:10 UTC
closing as XAA has been deprecated.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.