Bug 13223 - xserver-1.4 keyboard repeat rate strange behavior
xserver-1.4 keyboard repeat rate strange behavior
Status: RESOLVED DUPLICATE of bug 13114
Product: xorg
Classification: Unclassified
Component: Server/General
7.3 (2007.09)
Other All
: medium normal
Assigned To: Xorg Project Team
Xorg Project Team
Depends on:
  Show dependency treegraph
Reported: 2007-11-13 08:52 UTC by Ademar Reis
Modified: 2007-11-15 22:15 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Note You need to log in before you can comment on or make changes to this bug.
Description Ademar Reis 2007-11-13 08:52:57 UTC
As reported on the xorg-mailing list:

There's something wrong with the keyboard repeat rate, but I'm
not sure I understand it yet. Tests done using xserver-1.4 as on git branch origin/server-1.4-branch (last commit is 007e2239cf655...). Some symptoms:

5a: one of my keyboards now has a very high repeat rate by
default. Besides, if I change it to, for example, xset r rate 250
1, and keep a key pressed, I get one initial keypress event and
then after 250ms I start getting two keypress events at every
second (together).

5b: on another keyboard, I get what I call "keyboard repeat
(de)acceleration": if I set the repeat rate to 200/sec, for
example, I get this rate on the first initial events but
then the rate gets back to "normal" after a few milisecs. The
same with a rate of 1/sec or whatever value.

BTW, during my tests with a high repeat rate, sometimes events
are sent to a different window where the mouse is located. Maybe
the two problems are correlated. (Bug #13114)
Comment 1 Peter Hutterer 2007-11-13 14:48:21 UTC
Can you please try again with the patch I put forward for #13114. this should fix 5a, not sure about 5b though.
Comment 2 Ademar Reis 2007-11-14 07:47:25 UTC
Both problems are gone after applying the patch from bug #13114. Thanks!
Comment 3 Peter Hutterer 2007-11-15 22:15:07 UTC

*** This bug has been marked as a duplicate of bug 13114 ***