Bug 13230 - SubSection "Display" Causing Server to Hang with xserver-xorg-video-ati 6.7.196
Summary: SubSection "Display" Causing Server to Hang with xserver-xorg-video-ati 6.7.196
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/General (show other bugs)
Version: 7.3 (2007.09)
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: xorg-7.4
  Show dependency treegraph
 
Reported: 2007-11-13 14:01 UTC by James Spencer
Modified: 2008-05-28 00:06 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Xorg.0.log (25.76 KB, patch)
2007-11-13 14:01 UTC, James Spencer
no flags Details | Splinter Review
xorg.conf (2.48 KB, text/plain)
2007-11-13 14:02 UTC, James Spencer
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description James Spencer 2007-11-13 14:01:20 UTC
As of driver 6.7.196 whenever I start on XServer with SubSection "Display" in the Section "Screen" of my xorg.conf the server hangs and CTRL + ALT + Backspace doesn't restart it. The solution was to simply comment this section of the conf file, but the behaviour wasn't very graceful.

I've attached the log and a conf file.
Comment 1 James Spencer 2007-11-13 14:01:49 UTC
Created attachment 12520 [details] [review]
Xorg.0.log
Comment 2 James Spencer 2007-11-13 14:02:07 UTC
Created attachment 12521 [details]
xorg.conf
Comment 3 Alex Deucher 2007-12-11 09:28:42 UTC
This sounds like an xserver issue.
Comment 4 Michel Dänzer 2008-05-27 23:06:18 UTC
Is this still reproducible with the current driver and the xserver 1.5 branch? If so, can you try atttaching gdb to the X server process when it hangs, getting a backtrace and attaching it?
Comment 5 James Spencer 2008-05-27 23:14:31 UTC
As of whatever versions of the xserver and ati driver are shipping today in Debian experimental / unstable the problem is gone. Feel free to close. Thanks.

(I just uncommented the lines and CTRL + ALT + Backspaced... Nope, no hang.)


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.