Bug 13290 - YCbCr textures have chroma components swapped
Summary: YCbCr textures have chroma components swapped
Status: RESOLVED DUPLICATE of bug 11478
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: haihao
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-11-17 14:03 UTC by David Schleef
Modified: 2008-01-04 14:24 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Description David Schleef 2007-11-17 14:03:35 UTC
YCbCr textures have chroma components swapped.  This appears to be a driver issue, since it works correctly on another system with the ATI driver.  Also, this is a regression from ubuntu feisty.

Version: 2.1.1-0ubuntu9
Comment 1 David Schleef 2007-11-26 01:30:15 UTC
(--) Chipset 945GM found
Comment 2 Eric Anholt 2007-11-27 14:07:16 UTC
Since you say textures, I assume this is with OpenGL apps?  I just tested on a 945GM and the yuvsquare and yuvrect tests look fine.  Can you clarify the environment you're seeing the problem in?  What mesa version?  What application?
Comment 3 David Schleef 2007-11-27 15:00:28 UTC
I'm using http://www.schleef.org/~ds/xvideo_test, with xvimagesink changed to glimagesink.  glimagesink has been tested on a wide variety of drivers and cards, and used to work on this card with an older driver.

mesa is 7.0.1-1ubuntu3
Comment 4 Michael Fu 2008-01-03 22:06:14 UTC
might be related with bug# 11478...
Comment 5 David Schleef 2008-01-04 14:24:29 UTC

*** This bug has been marked as a duplicate of bug 11478 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.