Bug 13434 - Dual head not working on 9100 IGP
Summary: Dual head not working on 9100 IGP
Status: RESOLVED DUPLICATE of bug 11801
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/Radeon (show other bugs)
Version: 7.2 (2007.02)
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: xf86-video-ati maintainers
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-11-28 14:40 UTC by Eric Callier
Modified: 2009-10-19 07:08 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
xrandr -q output (806 bytes, text/plain)
2007-11-28 14:41 UTC, Eric Callier
no flags Details
Xorg.0.log (202.33 KB, patch)
2007-11-28 14:44 UTC, Eric Callier
no flags Details | Splinter Review
xorg.conf (7.53 KB, application/octet-stream)
2007-11-28 14:45 UTC, Eric Callier
no flags Details
sudo radeontool regs (492 bytes, text/plain)
2007-11-29 14:52 UTC, Eric Callier
no flags Details
sudo radeontool regs with fglrx big desktop (492 bytes, text/plain)
2007-12-02 11:08 UTC, Eric Callier
no flags Details
radeontool regmatch '*' with fglrx driver (14.71 KB, text/plain)
2007-12-05 14:53 UTC, Eric Callier
no flags Details
radeontool regmatch '*' with radeon driver (14.71 KB, text/plain)
2007-12-07 14:21 UTC, Eric Callier
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Callier 2007-11-28 14:40:19 UTC
I've got two monitor (Syncmaster 172x) on connected on the VGA socket, one on the DVI socket of an radeon 9100 IGP (Asus Pundit-R)

Before Upgrade I was using fglrx driver on an Xorg 6.8 my big desktop was working fine.   
Now after upgrade to Kubuntu 7.10 (Xorg 7.2) I'm able to make the DVI screen work with the radeon driver (With vesa I'm  able to get clone mode)

xrandr -q show VGA-0 connected & DVI-0 connected

xorg.log say :
/var/log/Xorg.0.log:(WW) RADEON(0): No External TMDS Table found
/var/log/Xorg.0.log:(WW) RADEON(0): Option "MonitorLayout" is not used
/var/log/Xorg.0.log:(WW) RADEON(0): Option "CRT2Position" is not used

with
xrandr --output DVI-0 --right-of VGA-0 

the DVI-0 stay black ?
I don't understand what happen ?
Comment 1 Eric Callier 2007-11-28 14:41:18 UTC
Created attachment 12804 [details]
xrandr -q output
Comment 2 Eric Callier 2007-11-28 14:44:37 UTC
Created attachment 12805 [details] [review]
Xorg.0.log
Comment 3 Eric Callier 2007-11-28 14:45:23 UTC
Created attachment 12806 [details]
xorg.conf
Comment 4 Alex Deucher 2007-11-28 17:00:58 UTC
Does the DVI port work in text mode or when the bios is active during boot?  Your setup uses an external TMDS chip, however no external tmds init table is available in the bios.  If the bios does not init the TMDS chip and there's not TMDS init table, the driver does not know how to power up the external TMDS chip which drives the DVI port.  fglrx apparently does.
Comment 5 Eric Callier 2007-11-29 14:01:21 UTC
In text mode DVI port is working in clone mode, the 2 screen display the same thing. 
I try with the vesa driver and I manage to make work clone mode but not bigdesktop or xinerama.
Comment 6 Alex Deucher 2007-11-29 14:32:17 UTC
(In reply to comment #5)
> In text mode DVI port is working in clone mode, the 2 screen display the same
> thing. 
> I try with the vesa driver and I manage to make work clone mode but not
> bigdesktop or xinerama.
> 

Can you grab radeontool (http://gitweb.freedesktop.org/?p=users/airlied/radeontool.git;a=summary) and dump (as root) the registers under fglrx and radeon using the following command and attach them to this bug?

./radeontool regmatch '*'

I'll take a look at them and see what's going on.
Comment 7 Eric Callier 2007-11-29 14:52:40 UTC
Created attachment 12837 [details]
sudo radeontool regs
Comment 8 Eric Callier 2007-11-29 14:58:17 UTC
I had done only 'radeontool regs' with radeon 
I'm not able to instal fglrx 8.28.8 with kunbuntu 7.10 (Xorg 7.2)
Comment 9 Alex Deucher 2007-11-30 14:29:58 UTC
(In reply to comment #8)
> I had done only 'radeontool regs' with radeon 
> I'm not able to instal fglrx 8.28.8 with kunbuntu 7.10 (Xorg 7.2)
> 

Unfortunately, I can't do much without the fglrx dump.
Comment 10 Eric Callier 2007-12-02 11:08:48 UTC
Created attachment 12909 [details]
sudo radeontool regs with fglrx big desktop

An working big desktop with ati driver 8.28.8 (fglrx) (kubuntu 6.06 / xorg 7.0)
Comment 11 Alex Deucher 2007-12-04 21:38:43 UTC
Unfortunately, I need the dumps using the latest version of radeontool here:
http://gitweb.freedesktop.org/?p=users/airlied/radeontool.git;a=summary
The version you used does not provide a full register dump.

git clone git://people.freedesktop.org/~airlied/radeontool
cd radeontool
make
sudo ./radeontool regmatch '*'
Comment 12 Eric Callier 2007-12-05 14:53:04 UTC
Created attachment 12967 [details]
radeontool regmatch '*' with fglrx driver

is it the correct version ?
Comment 13 Alex Deucher 2007-12-05 20:14:30 UTC
(In reply to comment #12)
> Created an attachment (id=12967) [details]
> radeontool regmatch '*' with fglrx driver
> 
> is it the correct version ?
> 

Yes perfect!  please also attach to log from the radeon driver as well.
Comment 14 Eric Callier 2007-12-07 14:21:29 UTC
Created attachment 12996 [details]
radeontool regmatch '*' with radeon driver

I hope that will help you
Comment 15 Alex Deucher 2007-12-09 20:51:01 UTC
Does DVI work with the radeon driver in clone mode?  Also did you run radeontool from within X or from a console?  It should be run from within X.  Unfortunately, it looks like the radeontool output is garbage.
Comment 16 Eric Callier 2007-12-09 23:52:41 UTC
I run radeontool within X (in an xterm) . I've only the VGA screen working the DVI screen stay black. I try CRT2Position  ="leftOf" and "Clone", but DVI still stay black

(WW) RADEON(0): No External TMDS Table found
(WW) RADEON(0): Direct rendering disabled
(WW) RADEON(0): Option "MonitorLayout" is not used
(WW) RADEON(0): Option "CRT2Position" is not used
 
$ xrandr -q
Screen 0: minimum 320 x 200, current 1280 x 1024, maximum 1280 x 1200
VGA-0 connected 1280x1024+0+0 (normal left inverted right) 338mm x 270mm
...
DVI-0 connected 1280x1024+0+0 (normal left inverted right) 338mm x 270mm
...
Comment 17 Rolf Leggewie 2008-02-01 01:31:37 UTC
I have similar problems also on Ubuntu gutsy with a Thinkpad X24 (M6 LY chip).  Does it make sense I participate in this bug or should I file a separate one?
Comment 18 Alex Deucher 2008-02-01 07:09:53 UTC
(In reply to comment #17)
> I have similar problems also on Ubuntu gutsy with a Thinkpad X24 (M6 LY chip). 
> Does it make sense I participate in this bug or should I file a separate one?
> 

Please file a different bug.  this is related specifically to IGP chips that need some additioanl driver work to function.  Your chip should work out of the box.
Comment 19 Alex Deucher 2009-10-19 07:08:45 UTC

*** This bug has been marked as a duplicate of bug 11801 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.