Bug 13613 - 120 wakeups/s with Radeon XPress 200M
Summary: 120 wakeups/s with Radeon XPress 200M
Status: RESOLVED DUPLICATE of bug 13610
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/Radeon (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: xf86-video-ati maintainers
QA Contact: Xorg Project Team
Depends on:
Reported: 2007-12-11 22:32 UTC by Javier Kohen
Modified: 2007-12-12 07:26 UTC (History)
0 users

See Also:
i915 platform:
i915 features:

XRandr output before --off/after --auto (608 bytes, text/plain)
2007-12-11 22:43 UTC, Javier Kohen
no flags Details
XRandr output after --off (584 bytes, text/plain)
2007-12-11 22:44 UTC, Javier Kohen
no flags Details
X.org configuration (5.47 KB, text/plain)
2007-12-11 22:45 UTC, Javier Kohen
no flags Details
X.org log (152.59 KB, text/plain)
2007-12-11 22:46 UTC, Javier Kohen
no flags Details
Simplified X.org configuration (2.87 KB, text/plain)
2007-12-12 00:41 UTC, Javier Kohen
no flags Details
X.org log for simplified configuration (49.73 KB, text/plain)
2007-12-12 00:42 UTC, Javier Kohen
no flags Details

Description Javier Kohen 2007-12-11 22:32:47 UTC
I noticed my XPress200M is doing 120 wakeups/s on my laptop. I'm using XOrg 7.3/1.4.1~git20071119, radeon 6.7.196 and Mesa 7.1~20070824. DRI and Composite are enabled (but Xorg is the only client according to /dev/dri/card0). The kernel is and I'm not using dual-heal, only the laptop's panel. However, I do have several devices defined in xorg.conf (since I used to have a CRT), but only the panel is referenced in the current screen layout "Single LVDS" (see attached).

I just found out that xrandr reported VGA-0 on unknown connector. I used xrandr to disable it and the wakeups went down to 0. Which allowed the CPU to reach state C3. Then I set it back to auto and the wakeup count went again up to 60. I set it back off, but it stayed in 60 and the CPU doesn't reach state C3 anymore. This seems buggy. Also, I have nothing plugged to VGA-0, so it should be off by default, right?
Comment 1 Alex Deucher 2007-12-11 22:36:40 UTC
XPRESS support is generally buggy as it was added by trial and error.  Hopefully that will change soon.  In any case, please attach your xorg log, config, and xrandr output.
Comment 2 Javier Kohen 2007-12-11 22:43:36 UTC
Created attachment 13050 [details]
XRandr output before --off/after --auto
Comment 3 Javier Kohen 2007-12-11 22:44:43 UTC
Created attachment 13051 [details]
XRandr output after --off
Comment 4 Javier Kohen 2007-12-11 22:45:41 UTC
Created attachment 13052 [details]
X.org configuration
Comment 5 Javier Kohen 2007-12-11 22:46:55 UTC
Created attachment 13053 [details]
X.org log
Comment 6 Javier Kohen 2007-12-12 00:41:22 UTC
Created attachment 13058 [details]
Simplified X.org configuration
Comment 7 Javier Kohen 2007-12-12 00:42:04 UTC
Created attachment 13059 [details]
X.org log for simplified configuration
Comment 8 Javier Kohen 2007-12-12 00:51:19 UTC
I found out that when X is restarted I get no interrupts from the card and 3D works alright. However, it goes up to 120 as soon as I switch back and forth from the Linux (text) console, so I guess switching to the console is what triggers this problem.

I tried turning off DynamycClocks to no avail. I also tried enabling framebuffer on the console, but radeonfb caused so much trouble (crashes, frozen computer, garbage on the screet, etc.) that I didn't even get to test if it helped the issue.

Also, I can't seem to get the interrupt back to 60Hz ―it's either 0 or 120 now― so that apparently was just another buggy case.
Comment 9 Alex Deucher 2007-12-12 07:26:52 UTC

*** This bug has been marked as a duplicate of bug 13610 ***

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.