Bug 13809 - vbo error with GtkRadiant on Intel i915, x86_32
vbo error with GtkRadiant on Intel i915, x86_32
Status: RESOLVED DUPLICATE of bug 13100
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i915
x86 (IA32) Linux (All)
: medium normal
Assigned To: Zou Nan hai
Depends on:
  Show dependency treegraph
Reported: 2007-12-24 10:49 UTC by Taiyo Rawle
Modified: 2007-12-28 11:07 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Note You need to log in before you can comment on or make changes to this bug.
Description Taiyo Rawle 2007-12-24 10:49:14 UTC
GtkRadiant, a map editor program for Quake like games causes this error:

radiant: vbo/vbo_split_inplace.c:97: flush_vertex: Assertion `max_index >= min_index' failed.

This happens on a Dell Latitude D610 laptop which uses an x86_32 processor and Intel i915 graphics. This appears to be the same problem as described here: 

Radiant starts and I can load small maps, but the crash happens when I attempt to work on large complex maps. The crash happens with a version of Radiant that was precompiled and the latest SVN version that I compiled. I am using Kubuntu Gusty. The bug happens with both the "i810" and the "intel" xorg drivers.

This bug does not occur on my desktop which is x86_64 with Intel G965 graphics, Fedora 8.

glxinfo gives this information:

OpenGL vendor string: Tungsten Graphics, Inc
OpenGL renderer string: Mesa DRI Intel(R) 915GM 20061017 x86/MMX/SSE2
OpenGL version string: 1.3 Mesa 7.0.1

Apologies if this is a duplicate of bug 13100, but according to https://bugs.freedesktop.org/show_bug.cgi?id=13100 this was fixed in mesa_7_0_branch, and this happened with mesa 7.0.1
Comment 1 Roland Scheidegger 2007-12-28 11:07:39 UTC
Note that mesa_7_0_branch is what's used to develop all of the 7.0.x releases. This particular fix was added between 7.0.1 and 7.0.2.

*** This bug has been marked as a duplicate of bug 13100 ***