Bug 14073 - [32bit i915]openarena freeze tty with Assertion `intel->batch->id == intel->last_state_batch_id' failed
Summary: [32bit i915]openarena freeze tty with Assertion `intel->batch->id == intel->l...
Status: VERIFIED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i915 (show other bugs)
Version: git
Hardware: Other Linux (All)
: high critical
Assignee: Eric Anholt
QA Contact:
URL:
Whiteboard:
Keywords:
: 14104 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-01-14 18:44 UTC by Colin.Joe
Modified: 2009-08-24 12:29 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Xorg.0.log (71.91 KB, text/plain)
2008-01-14 18:46 UTC, Colin.Joe
Details
backtrace (1.72 KB, text/plain)
2008-01-14 18:47 UTC, Colin.Joe
Details

Description Colin.Joe 2008-01-14 18:44:04 UTC
System Environment:
--------------------------

--Platform:945gm 915gm bearlake
--Architecture(32-bit,64-bit,compatiblity): 32bit 

kernel: 
2.6.23

drm   
commit 62df4f0a48776e55443d7f61a41e1ed0fb77b6ed

mesa 
commit 544ab209e75ec3646d7edbafd736dcf4c93738cc  

xf86_video_intel 
commit 4fec18e07f2b23306e885d63c74661ae0e4b04d9  

xserver   
commit 180a5aba4de3104fed8bc4e7d42a1e3a51575318

Bug detailed description:
--------------------------
startx , run openarena , it soon hang system .


Reproduce steps:
----------------
run openarena


Current result:
----------------
hang system


Expected result:
----------------
run normally
Comment 1 Colin.Joe 2008-01-14 18:46:24 UTC
Created attachment 13714 [details]
Xorg.0.log
Comment 2 Colin.Joe 2008-01-14 18:47:10 UTC
Created attachment 13715 [details]
backtrace
Comment 3 Shuang He 2008-01-14 19:23:15 UTC
it seems following commit brings in this issue:

commit a04b632350e5d0e9994fc667afc59407a39da0ba
Author: Eric Anholt <eric@anholt.net>
Date:   Thu Jan 10 10:48:05 2008 -0800

    [intel] Add more cliprect modes to cover other meanings for batch emits.

    The previous change gave us only two modes, one which looped over the batch
    per cliprect (3d drawing) and one that didn't (state updeast).
    However, we really want 4:

    - Batch doesn't care about cliprects (state updates)
    - Batch needs DRAWING_RECTANGLE looping per cliprect (3d drawing)
    - Batch needs to be executed just once (region fills, copies, etc.)
    - Batch already includes cliprect handling, and must be flushed by unlock ti
      (copybuffers, clears).

    All callers should now be fixed to use one of these states for any batchbuff
    emits.  Thanks to Keith Whitwell for pointing out the failure.
Comment 4 Shuang He 2008-01-14 19:32:00 UTC
it doesn't hang the system.
it can be connected from other machine.
Comment 5 Shuang He 2008-01-14 21:15:18 UTC
run with:
./glean -r test -t +fpexceptions
can reproduce the same problem. but it will not freeze tty.
Comment 6 Eric Anholt 2008-01-15 17:08:57 UTC
I failed to push some changes on Monday, need to grab them and test again on master.
Comment 7 Shuang He 2008-01-15 18:43:26 UTC
I have tried latest git. the issue still exists.
are the changes committed in?
Comment 8 Shuang He 2008-01-16 20:50:20 UTC
*** Bug 14104 has been marked as a duplicate of this bug. ***
Comment 9 Eric Anholt 2008-01-17 15:38:37 UTC
Pushed my patch today, which got OA working for me.
Comment 10 Adam Jackson 2009-08-24 12:29:10 UTC
Mass version move, cvs -> git


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.