Bug 142 - Framebuffer driver does not compile against 2.6 kernel headers
Summary: Framebuffer driver does not compile against 2.6 kernel headers
Status: CLOSED WONTFIX
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/DDX/Xephyr (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: Keith Packard
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-11-13 04:01 UTC by ismail donmez
Modified: 2011-10-15 17:20 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Description ismail donmez 2003-11-13 04:01:04 UTC
FramBuffer interface is changed in Linux Kernel 2.6 and looks like kdrive FB 
driver does not support new interface.
Comment 1 Michel Dänzer 2004-03-04 10:30:18 UTC
The interface to userspace shouldn't have changed in an incompatible way; there
were bugs in the header files though which have only been fixed recently. Is
there still a problem with the 2.6.3 kernel?
Comment 2 Stéphane Loeuillet 2004-07-26 06:40:53 UTC
any news about this bug with 2.6.7 or early 2.6.8 ?

closing soon if no news
Comment 3 ismail donmez 2004-07-26 11:59:19 UTC
Will re open when I got X.org source again.
Comment 4 Daniel Stone 2007-03-26 08:31:10 UTC
reopening all RESOLVED/{LATER,REMIND} bugs.  now is later, and this is a reminder. ;)
Comment 5 Adam Jackson 2009-04-14 07:17:49 UTC
The old kdrive tree is dead.  As far as we can tell, this bug no longer applies to the current Xorg server tree.  If it does, please reopen this bug and change the product to 'xorg' and the component to 'server/general'.
Comment 6 Jeremy Huddleston Sequoia 2011-09-27 10:19:53 UTC
Mass update: Close all bugs resolved over one year ago.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.