Bug 14210 - Zooming in Firefox3 breaks images
Summary: Zooming in Firefox3 breaks images
Status: RESOLVED DUPLICATE of bug 13795
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/Acceleration/XAA (show other bugs)
Version: 7.3 (2007.09)
Hardware: Other All
: medium normal
Assignee: Timo Aaltonen
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords: NEEDINFO
Depends on:
Blocks:
 
Reported: 2008-01-23 02:27 UTC by Timo Aaltonen
Modified: 2008-04-03 06:57 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Timo Aaltonen 2008-01-23 02:27:47 UTC
Forwarded from https://launchpad.net/bugs/182038 :

"Firefox 3.0 renders images fine at the default zoom, but for certain images shows only a black rectangle when the zoom is changed (by control-+ or control--). See e.g. this page:

http://www.everex.com/

There is a big image of a laptop on the right. This turns into a black rectangle when the zoom is not the default.

This is on a fresh install of Hardy Heron Alpha 3. I am using the "nv" open-source driver if that is relevant."

the binary driver works ok.
Comment 1 Aaron Plattner 2008-01-24 17:54:17 UTC
Works fine for me on a Quadro FX 4000 with xorg-server 1.3.0 and xf86-video-nv 2.1.6.  Please attach an Xorg.0.log from a system that reproduces the problem.
Comment 2 Raúl Porcel 2008-01-25 03:59:31 UTC
This is not only on the nv driver. Happens the same with ati and intel. Only happens when using xorg-server-1.4.

However, using EXA as the AccelMethod fixes it on ati and intel.
Comment 3 Aaron Plattner 2008-01-31 10:20:02 UTC
Thanks, Raúl.  Moving to Acceleration/XAA.
Comment 4 Adam Jackson 2008-03-03 20:25:55 UTC
Pretty sure this is the same as bug #13795.

*** This bug has been marked as a duplicate of bug 13795 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.