Bug 14253 - 2.2.0: virtual terminals don't display
Summary: 2.2.0: virtual terminals don't display
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Mark Wagner
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-01-25 19:24 UTC by Mark Wagner
Modified: 2008-01-27 04:05 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Xorg.log (104.17 KB, text/plain)
2008-01-26 18:54 UTC, Mark Wagner
no flags Details
xorg.conf (3.48 KB, text/plain)
2008-01-26 18:56 UTC, Mark Wagner
no flags Details

Description Mark Wagner 2008-01-25 19:24:14 UTC
Steps to reproduce:
1) Start X
2) Press ctrl+alt+F1

Expected results:
Virtual terminal 1 to show up.

Actual results:
The monitor goes blank and indicates no signal or signal out of range.  The system has switched to the virtual terminal -- I can type commands and things will happen -- I just can't see anything.

This can also be triggered by starting the X server and then exiting it.  It occurs with both the 1.3 and 1.4 servers, but does not occur with the 2.1.1 Intel video driver.
Comment 1 Michael Fu 2008-01-26 17:42:58 UTC
please attach your xorg.conf xorg.log and specify details of your HW, e.g. model name if a laptop or mobo model if a desktop.

there is a similar bug on VT switch. I'll appreciate if you can test bug# 14249 to see if you can reproduce it or not. thanks.
Comment 2 Mark Wagner 2008-01-26 18:54:29 UTC
Created attachment 13968 [details]
Xorg.log
Comment 3 Mark Wagner 2008-01-26 18:56:15 UTC
Created attachment 13969 [details]
xorg.conf
Comment 4 Mark Wagner 2008-01-26 19:00:41 UTC
(In reply to comment #1)
> please attach your xorg.conf xorg.log and specify details of your HW, e.g.
> model name if a laptop or mobo model if a desktop.
> 
> there is a similar bug on VT switch. I'll appreciate if you can test bug# 14249
> to see if you can reproduce it or not. thanks.
> 

Hardware is a P5E-VM HDMI mainboard, Q6600 CPU, 4GB RAM.

Testing bug# 14249 seems rather pointless: since all VT switches fail for me, I wouldn't be able to tell one triggered by a suspend-to-ram from what's happening right now.
Comment 5 Gordon Jin 2008-01-27 04:05:18 UTC
A VT switch bug has been fixed after 2.2.0 released. Please try the git tip or the upcoming 2.2.1 release. Please reopen if you still see the same problem with the new driver.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.