Bug 14446 - Lockup on Xorg Exit/Restart/VT Switch
Summary: Lockup on Xorg Exit/Restart/VT Switch
Status: RESOLVED DUPLICATE of bug 15056
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/Radeon (show other bugs)
Version: git
Hardware: PowerPC Linux (All)
: low normal
Assignee: xf86-video-ati maintainers
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-02-09 13:44 UTC by Mike Skinner
Modified: 2008-03-18 15:45 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
xorg.conf (2.19 KB, text/plain)
2008-02-09 13:44 UTC, Mike Skinner
no flags Details
Xorg.0.log (68.72 KB, text/plain)
2008-02-09 13:45 UTC, Mike Skinner
no flags Details
Xorg.0.log Xorg Server 1.4 (50.53 KB, text/plain)
2008-02-19 21:22 UTC, Mike Skinner
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Skinner 2008-02-09 13:44:43 UTC
Created attachment 14250 [details]
xorg.conf

Hi,

This is my first bug on freedesktop.org, I apologise in advance if the bug is filled out incorrectly, or if you do not agree with the severity or priority.

Problem:
In X, whenever I select to:
* logout of X (ie: to switch user),
* shutdown,
* restart,
* Press the Ctrl-Alt-Backspace combo,
the system freezes and the screen goes black and reports "no input signal". Ctrl-Alt-Delete doesn't do anything, and I don't believe the magic sysreq combo does either. The Mac Mini cooling fans come on and spin at full speed. The only option is to hold down the power button for several seconds to turn the PC off. This means that the partitions aren't cleanly unmounted, and recovery is needed upon the next startup.

System: G4 PowerPC Mac Mini with ATI Radeon 9200 card:
0000:00:10.0 VGA compatible controller: ATI Technologies Inc RV280 [Radeon 9200] (rev 01)

Driver: Compiled from this GIT repo:
http://gitweb.freedesktop.org/?p=xorg/driver/xf86-video-ati.git;a=summary

$ git log |more
commit 8606c1bd175893c77e8c758246a1aed166c8be51
Author: George Sapountzis <gsap7@yahoo.gr>
Date:   Fri Feb 8 19:07:03 2008 +0200
    mach64: factor out BIOS panel info parsing

Kernel: Reproducible on 2.6.22 and 2.6.24.

Screen: 19" BenQ LCD connected via DVI, operating at 1280x1024/24 bit/59.9Hz.

In the past, I have had problems with no valid screens/modes detected, or blank screen on x startup - hence my desire to try the latest from GIT.

I have attached my xorg.conf - and I have tried removing all "Option" lines from within the "Device" section. I'm not running compiz as my card only has 32 MB RAM and doesn't support compiz at 24 bit colour @ 1280x1024.

I am happy to compile and test possible solutions.
Comment 1 Mike Skinner 2008-02-09 13:45:20 UTC
Created attachment 14251 [details]
Xorg.0.log
Comment 2 Alex Deucher 2008-02-10 21:17:24 UTC
Does disabling the DRI help?

Option "DRI" "False"
Comment 3 Mike Skinner 2008-02-10 23:11:34 UTC
Hi Alex,

The same behaviour occurs when DRI is disabled.

Kind Regards,

Mike
Comment 4 Mike Skinner 2008-02-19 21:21:16 UTC
I have noticed an additional symptom: attempting to switch to a virtual terminal after X has started (eg: Ctrl-Alt-F6) results in a lockup as well. I assume it's related, however I could be wrong.

I am now running Xorg Server 1.4 (Hardy Alpha). I have attached the new X log too.


$ git log |more
commit b5bd442b60dbc72fe4c1e928ab864aeb0fd7a3cb
Author: Alex Deucher <alex@botch2.(none)>
Date:   Tue Feb 19 20:47:40 2008 -0500

    R100: fix render accel for transforms
    
    Not sure why we had a separate broken path for r100 vertex
    submission.

- Mike -
Comment 5 Mike Skinner 2008-02-19 21:22:00 UTC
Created attachment 14433 [details]
Xorg.0.log Xorg Server 1.4
Comment 6 Mike Skinner 2008-02-27 02:05:32 UTC
This issue also occurs using the DVI->analog adapter connecting a different LCD display.

When using the DVI-analog adapter, when the machine hangs on exiting from X, my monitor flashes an "out of range" message. I can't actually determine what the refresh rate is because the message appears/disappears too quickly.
Comment 7 Mike Skinner 2008-03-18 15:45:04 UTC
I'm marking this as a duplicate of bug #15056.

http://bugs.freedesktop.org/show_bug.cgi?id=15056

For the benefit of those reading this on bugs.freedesktop.org, appending the following in Yaboot was a good workaround for me:
video=radeonfb:1280x1024-24@60
(Obviously substitute your resolution, colour depth and refresh rate if you use this.)

*** This bug has been marked as a duplicate of bug 15056 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.