Bug 14584 - Keyboard VT switch not working
Summary: Keyboard VT switch not working
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/General (show other bugs)
Version: git
Hardware: PowerPC Linux (All)
: medium normal
Assignee: Daniel Stone
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: xorg-7.4
  Show dependency treegraph
 
Reported: 2008-02-20 05:12 UTC by Michel Dänzer
Modified: 2008-03-04 15:37 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Config file (3.40 KB, application/octet-stream)
2008-02-20 05:12 UTC, Michel Dänzer
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michel Dänzer 2008-02-20 05:12:14 UTC
Created attachment 14448 [details]
Config file

First of all, I bisected the symptoms described below to be caused by commit fbd776894658e7afb2c55dc8582b2a3efab78a3c (XKB: Ditch XkbFileInfo). Reverting just that commit against current master makes things work as expected.

The first symptom is that ctrl-alt-Fx fails to switch to console.

The second symptom is weirder and may be harder to reproduce. The following recipe worked for me every time, but it may depend on some settings of mine: Start X with

 xinit $(which xterm)

In the xterm, run

 gnome-settings-daemon &
 compiz &

Maximize the xterm window and start typing 'gnome-keyboard-properties' (I wanted to check if the first symptom was related to XKB configuration - it's not BTW). Somewhere around the first 'e' or '-' the X server terminates without any indication of a crash or other problem.

I'm attaching my rather messy xorg.conf, in case it matters. Let me know if you need something else - FWIW, the log file seems identical with or without that commit.
Comment 1 Michel Dänzer 2008-02-20 05:29:45 UTC
Oh, BTW, if you can't reproduce the second symptom, try also pressing ctrl-alt-Fx to attempt a VT switch first thing once X is up. This may or may not be necessary for triggering the second symptom as well.
Comment 2 Maarten Maathuis 2008-02-21 00:55:57 UTC
I too cannot switch VT's anymore, but i cannot be 100% sure (atm) it's that commit, it is however one of the xkb changes that happened recently. 
Comment 3 Michel Dänzer 2008-02-21 01:55:20 UTC
(In reply to comment #2)

It's easy to verify - just try reverting that commit. :)

Though one possible difference is that I think I saw you mention on IRC that ctrl-alt-backspace doesn't work for you either, but it does for me even with that commit.
Comment 4 Maarten Maathuis 2008-02-21 03:58:27 UTC
Obviously i can verify it, and i will do it when i have the time. 
Comment 5 Maarten Maathuis 2008-02-21 09:56:32 UTC
I reverted that commit and it didn't work.

Backtrace:
0: X(xf86SigHandler+0x96) [0x46d9be]
1: /lib/libc.so.6 [0x2b64da70e1f0]
2: X(SrvXkbApplyCompatMapToKey+0x506) [0x51b181]
3: X(XkbUpdateDescActions+0x37) [0x50bf2a]
4: X(XkbUpdateActions+0x60) [0x50c0b3]
5: X(XkbApplyMappingChange+0xa0) [0x50c3b9]
6: X(SendDeviceMappingNotify+0x63) [0x4f7514]
7: X(ProcChangeKeyboardMapping+0x18b) [0x43e37d]
8: X(Dispatch+0x301) [0x444862]
9: X(main+0x521) [0x430723]
10: /lib/libc.so.6(__libc_start_main+0xf4) [0x2b64da6fb1f4]
11: X(FontFileCompleteXLFD+0x259) [0x42fb59]

I may try going back to the actual commit, but not now.
Comment 6 Michel Dänzer 2008-02-21 10:09:30 UTC
(In reply to comment #5)
> I reverted that commit and it didn't work.

Probably a different issue then, please file a separate bug.
Comment 7 Mathieu Bérard 2008-02-21 14:21:28 UTC
That bug also prevents some keys of my French keyboard from producing any character. This includes accented letters and the euro currency sign.

That may prevent users from login from their display manager.

There is no trace of any error in my Xorg.0.log.

Reverting fbd776894658e7afb2c55dc8582b2a3efab78a3c works

My keyboard config block is:

Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "kbd"
        Option          "CoreKeyboard"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc105"
        Option          "XkbLayout"     "fr"
        Option          "XkbVariant"    "oss"
EndSection
Comment 8 Bill Nottingham 2008-02-21 22:39:38 UTC
I'm seeing similar issues with a git snapshot from today as well, in short:

- ctrl-alt-backspace does not work
- ctrl-alt-{F1,F2,...} does not work
- the arrow keys do not work (and in some cases, emit very strange things)

Originally filed as https://bugzilla.redhat.com/show_bug.cgi?id=433917 in my case.
Comment 9 Daniel Stone 2008-02-22 00:51:09 UTC
On Wed, Feb 20, 2008 at 05:12:15AM -0800, bugzilla-daemon@freedesktop.org wrote:
> First of all, I bisected the symptoms described below to be caused by commit
> fbd776894658e7afb2c55dc8582b2a3efab78a3c (XKB: Ditch XkbFileInfo). Reverting
> just that commit against current master makes things work as expected.
> 
> The first symptom is that ctrl-alt-Fx fails to switch to console.

Oops, I'm a fool.  The attached patch should fix it (assuming Bugzilla
supports attachments): it worked for me because I was setting the maps
by hand etc, which worked fine.

> The second symptom is weirder and may be harder to reproduce. The following
> recipe worked for me every time, but it may depend on some settings of mine:
> Start X with
> 
>  xinit $(which xterm)
> 
> In the xterm, run
> 
>  gnome-settings-daemon &
>  compiz &
> 
> Maximize the xterm window and start typing 'gnome-keyboard-properties' (I
> wanted to check if the first symptom was related to XKB configuration - it's
> not BTW). Somewhere around the first 'e' or '-' the X server terminates without
> any indication of a crash or other problem.

Um, weird: works fine for me.  Does changing the keymap (setxkbmap
-model whatever -layout ch -variant de, or whatever) after you start the
server help at all?  Or does the attached patch just magically fix it?
Would be interesting to get a backtrace if possible.
Comment 10 Daniel Stone 2008-02-22 03:57:29 UTC
On Fri, Feb 22, 2008 at 08:57:35AM +0200, Daniel Stone wrote:
> Oops, I'm a fool.  The attached patch should fix it (assuming Bugzilla
> supports attachments): it worked for me because I was setting the maps
> by hand etc, which worked fine.

Guess it doesn't support attachments via mail.

http://people.freedesktop.org/~daniels/xkb-initial-map-set.diff
Comment 11 Bill Nottingham 2008-02-22 05:13:16 UTC
That patch fixes ctrl-alt-f1 for me, although it doesn't fix the other keyboard weirdness I'm seeing. Which could be unrelated.
Comment 12 Maarten Maathuis 2008-02-22 05:37:09 UTC
When i manually load a keymap i can VT switch, but i still get other strangeness. Iḿ just keeping an eye on this bug, and i´ll open another if i think it's desirable.
Comment 13 Daniel Stone 2008-02-22 09:21:40 UTC
On Thu, Feb 21, 2008 at 10:39:39PM -0800, bugzilla-daemon@freedesktop.org wrote:
> I'm seeing similar issues with a git snapshot from today as well, in short:
> 
> - ctrl-alt-backspace does not work
> - ctrl-alt-{F1,F2,...} does not work
> - the arrow keys do not work (and in some cases, emit very strange things)

The arrow keys issue is having the pc105 model selected instead of
evdev.
Comment 14 Michel Dänzer 2008-02-22 11:08:11 UTC
(In reply to comment #9)
> > Somewhere around the first 'e' or '-' the X server terminates without
> > any indication of a crash or other problem.

[...]

> Would be interesting to get a backtrace if possible.

Backtrace of what? (See above :)

Thanks for the fix, I'll give it a spin ASAP, though that may only be when I'm back from FOSDEM.
Comment 15 Søren Sandmann Pedersen 2008-02-26 12:11:41 UTC
Ctrl-Alt-Fn still don't work for me with current master.

Reverting fbd776894658e7afb2c55dc8582b2a3efab78a3c makes it work.

Comment 16 Michel Dänzer 2008-02-27 04:29:20 UTC
I can confirm that while the second problem is fixed with current master (thanks!), keyboard VT switching is still broken.

Something has changed though: When I originally reported this, pressing ctrl-alt-Fx resulted in some garbage input in terminals, but now it just doesn't seem to have any immediately visible effect.
Comment 17 Maarten Maathuis 2008-03-04 09:41:06 UTC
My situation is back to normal, after a recent fix.
Comment 18 Daniel Stone 2008-03-04 15:37:17 UTC
Yes, this was also fixed yesterday.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.