Bug 14874 (pk-update-icon) - dbus returns an error
Summary: dbus returns an error
Status: RESOLVED FIXED
Alias: pk-update-icon
Product: PackageKit
Classification: Unclassified
Component: core (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Richard Hughes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-03-07 00:06 UTC by fujisan
Modified: 2008-03-17 07:35 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description fujisan 2008-03-07 00:06:15 UTC
When running pk-update-icon, i got this error message:

$ pk-update-icon
libnm_glib_nm_state_cb: dbus returned an error.
  (org.freedesktop.DBus.Error.ServiceUnknown) The name org.freedesktop.NetworkManager was not provided by any .service files
Comment 1 fujisan 2008-03-07 00:09:53 UTC
my version of PK:

$ rpm -qa|grep -i packagekit
PackageKit-devel-0.1.10-0.540.20080304git.fc8.hughsie
PackageKit-0.1.10-0.540.20080304git.fc8.hughsie
gnome-packagekit-0.1.10-0.449.20080304git.fc8.hughsie
PackageKit-libs-0.1.10-0.540.20080304git.fc8.hughsie
Comment 2 Richard Hughes 2008-03-09 12:09:50 UTC
Does pk-update-icon crash or is a harmless warning?
Comment 3 fujisan 2008-03-10 01:07:55 UTC
When i boot my laptop, the update icon does not appear once I log in.

pk-update-icon doesn't seem to crash:

[root@localhost ~]# ps axf|grep pk
 3418 ?        Sl     0:00          \_ pk-update-icon

and when i run yum, i have updates.
Comment 4 Richard Hughes 2008-03-17 07:02:10 UTC
Is this reproducable? Did you shutdown the NetworkManager service?
Comment 5 fujisan 2008-03-17 07:35:47 UTC
I updated this morning to version 0.1.10-0.549.20080316git.fc8.hughsie and now it works fine.
NetworkManager was not working properly. No sign of any connection allthough I had one.
Now both are working fine.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.