Bug 15020 - radeonhd: LVDS: VGA restore: lvds signal out of sync: cycling colours.
Summary: radeonhd: LVDS: VGA restore: lvds signal out of sync: cycling colours.
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/radeonhd (show other bugs)
Version: 7.3 (2007.09)
Hardware: Other All
: medium normal
Assignee: Michael Gaber
QA Contact: Xorg Project Team
Depends on:
Reported: 2008-03-14 19:34 UTC by Michael Gaber
Modified: 2011-11-07 15:10 UTC (History)
6 users (show)

See Also:
i915 platform:
i915 features:

xorg log (424.43 KB, text/plain)
2008-03-14 19:34 UTC, Michael Gaber
no flags Details
This is my log. (42.28 KB, text/x-log)
2008-03-14 20:04 UTC, Darren Blaber
no flags Details
Patch to test. (1.67 KB, patch)
2008-04-03 09:58 UTC, Egbert Eich
no flags Details | Splinter Review
New patch, should apply better. (1.67 KB, patch)
2008-04-03 10:17 UTC, Egbert Eich
no flags Details | Splinter Review
another try... (2.02 KB, patch)
2008-04-03 10:37 UTC, Egbert Eich
no flags Details | Splinter Review
missing enum (413 bytes, patch)
2008-04-04 01:56 UTC, Egbert Eich
no flags Details | Splinter Review

Description Michael Gaber 2008-03-14 19:34:14 UTC
Created attachment 15134 [details]
xorg log

when i switch from X to console i sometimes stumble upon a flashing of the colored texts as seen on this video:

Comment 1 Michael Gaber 2008-03-14 19:54:17 UTC
this is an x1400 on a thinkpad t60
Comment 2 Darren Blaber 2008-03-14 20:00:03 UTC
I share what I believe to be the same issue.  I have a mobility x1400 on an inspiron e1705 notebook.  For me, when i switch from X to console i randomly come across a distorted vga console with text flashing in all different directions. Here is a video of the issue:
Comment 3 Darren Blaber 2008-03-14 20:04:13 UTC
Created attachment 15137 [details]
This is my log.
Comment 4 Luc Verhaegen 2008-04-03 08:54:12 UTC
I just got a t60p pushed in my hands by Christoph (now in cc), while it was displaying a flashing panel when restored.

There is no difference in restored registers, so it is not something that can be identified directly through that.

What i am seeing though, is that the MC hasn't idled properly in both the logs on here, and the log i grabbed from christophs laptop:
(WW) RADEONHD(0): MC not idle

So i guess that this a either good symptom of what is failing here or that it is a  seperate issue. Egbert knows the MC subsystem, so i am ccing him here as well. I think he had some ideas as to what could be going wrong with the mc...

Ok... something happened while this was being written. M54 seems to be related to the RV515, so it needs different handling. Assigning this bug to egbert until the MC issue is fixed.
Comment 5 Egbert Eich 2008-04-03 09:58:25 UTC
Created attachment 15652 [details] [review]
Patch to test.

Just received information taht M54 may be a RV515.
Comment 6 Egbert Eich 2008-04-03 10:17:50 UTC
Created attachment 15653 [details] [review]
New patch, should apply better.

The previous patch didn't contain all the pieces needed.
Comment 7 Egbert Eich 2008-04-03 10:37:28 UTC
Created attachment 15654 [details] [review]
another try...
Comment 8 Egbert Eich 2008-04-04 01:56:48 UTC
Created attachment 15672 [details] [review]
missing enum

This needs to be applied on top of the last patch.
Comment 9 Michael Gaber 2008-04-04 05:27:38 UTC
looks like the bug has gone away here after applying the two patches.
if dmb doesn't have any different experience i suggest closing this bug
Comment 10 Darren Blaber 2008-04-04 09:26:58 UTC
Well, VT switching is sure faster, but occasionally. I still get the issues shown from my videos posted earlier. 
Comment 11 Egbert Eich 2008-04-06 04:11:53 UTC
(In reply to comment #10)
> Well, VT switching is sure faster, but occasionally. I still get the issues
> shown from my videos posted earlier. 

Is this a problem that was introduced at some point (a regression) or has this happened all the time?

Comment 12 Darren Blaber 2008-04-06 09:21:04 UTC
Not 100% sure, but I think it existed since I started using the driver.
Comment 13 Yang Zhao 2008-04-10 09:00:42 UTC
I am still seeing this on my Mobility Radeon X1300 on a ThinkPad T60, except in my X session instead of console VT. Symptom is otherwise identical to the video posted by the reporter.

Happens very rarely, and seems to happen mostly on hibernate resume. Unsure about suspend-to-ram as I rarely use it. Switching back and forth between VTs will remove it after a try or two.

No verbose 7 log, yet, unfortunately. Unsure if this is a regression or not as I've had my Xorg version updated in the last month.
Comment 14 Felipe Contreras 2008-04-22 00:57:09 UTC
This has existed all the time.

Actually I saw this on the avivo driver too.
Comment 15 Luc Verhaegen 2008-05-16 15:40:39 UTC
A PLL to CRTC mapping fix just went into the main tree. While it fixes another major issue we had with panel restore, it could also affect this. Please try the latest git driver.
Comment 16 Yang Zhao 2008-05-18 11:09:43 UTC
Issue still persists, although appears to be more consistent now, at least.

Will attempt to get some testing done it later.
Comment 17 Luc Verhaegen 2008-05-21 18:19:21 UTC
Ok, another fix for the same thing (PLL ownership) went in now. I doubt that this does this resolve the issue now, but there's some chance that it does.
Comment 18 Luc Verhaegen 2008-05-27 07:20:08 UTC
Please check fcb4fef67c993 in git: PLL: On M54 do not re-enable Spread Spectrum.

I kind of cheated my way out of this one, but it will hopefully resolve a longstanding issue in a good enough manner with the limited amount of time i have had with hardware.
Comment 19 Yang Zhao 2008-05-27 17:50:14 UTC
Haven't seen the error again yet. I've only tried reproducing it once so far, but so far so good.
Comment 20 Christopher Stender 2008-05-28 08:33:47 UTC
It is working quite well on my T60. Thanks Luc!
Comment 21 Yang Zhao 2008-05-29 08:07:41 UTC
Still occurring after coming out of hibernation, unfortunately.
Comment 22 Jörg Mayer 2008-06-07 07:10:08 UTC
I have the same problem (on a T60 with X1400 as well) with current git. So I wanted to try the patch but it has diverged from current code base that I couldn't even apply it by hand.
Could someone please create an updated patch?
Comment 23 Yang Zhao 2008-06-07 08:15:46 UTC
(In reply to comment #22)
> Could someone please create an updated patch?

The patch was committed to mainline quite some time ago. You will already be using it if you are running the latest from git.
Comment 24 Jörg Mayer 2008-06-08 08:09:16 UTC
OK, so that means the problem is still present and not fixed by that patch as far as I am concerned.
Comment 25 Jeremy Huddleston Sequoia 2011-10-16 15:58:26 UTC
Does this issue occur with the preferred ati driver (xf86-vide-ati)?  If so, please move this to the Driver/Radeon component.  

Development of radeonhd has pretty much halted and development focus is on the ati driver.  Please see http://www.x.org/wiki/radeonhd

If the issue does not exist in the ati driver (or if there is no response to this message), this bug will be closed as WONTFIX unless someone contributes a patch.
Comment 26 Jeremy Huddleston Sequoia 2011-11-07 15:10:38 UTC
Closing due to lack of response.  Please reopen and move to the Driver/Radeon 
component if this issue persists with xf86-video-ati

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.