Bug 15106 - Intel 2.2.1 driver refuses to start up if no display is connected
Summary: Intel 2.2.1 driver refuses to start up if no display is connected
Status: RESOLVED DUPLICATE of bug 14611
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium critical
Assignee: Gordon Jin
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-03-18 08:38 UTC by Simon Farnsworth
Modified: 2008-03-18 16:54 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
X configuration (1.68 KB, text/plain)
2008-03-18 08:38 UTC, Simon Farnsworth
no flags Details
Log of failing startup (17.19 KB, text/plain)
2008-03-18 08:39 UTC, Simon Farnsworth
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Farnsworth 2008-03-18 08:38:20 UTC
Created attachment 15251 [details]
X configuration

The 2.2.1 release of the Intel driver refuses to start if no screen is connected, despite a X configuration file telling it to go ahead anyway. The configuration used is attached.
Comment 1 Simon Farnsworth 2008-03-18 08:39:06 UTC
Created attachment 15252 [details]
Log of failing startup

And the logfile Xorg generates when we start up without a display
Comment 2 Simon Farnsworth 2008-03-18 09:55:56 UTC
Found the cause, and a workaround for us:

xf86ProbeOutputModes in Xorg's hw/xfree86/modes/xf86Crtc.c doesn't set up any modes for outputs that are definitely disconnected (output control function returns XF86OutputStatusDisconnected).

i830_crt_detect in the driver's src/i830_crt.c returns XF86OutputStatusDisconnected if one of the believed reliable detection methods returns false. The interaction between the two ensures that there are no modes available for a disconnected output.

In our situation, we can work around this by replacing XF86OutputStatusDisconnected with XF86OutputStatusUnknown in i830_crt_detect.
Comment 3 Michael Fu 2008-03-18 16:54:52 UTC
dup of bug# 14611...known behaviour for now. we will see if we would take this as a feature and will then reopen... thanks.

*** This bug has been marked as a duplicate of bug 14611 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.