Bug 15190 - [SiS] 771/671 PCIE VGA Display Adapter [1039:6351]
Summary: [SiS] 771/671 PCIE VGA Display Adapter [1039:6351]
Status: RESOLVED MOVED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/SiS (show other bugs)
Version: unspecified
Hardware: Other All
: medium major
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
: 29668 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-03-24 08:43 UTC by Mirko
Modified: 2018-08-10 20:47 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mirko 2008-03-24 08:43:40 UTC
I have a [SiS] 771/671 PCIE VGA Display Adapter [1039:6351] (rev 10) driver from xorg doesn't have support for my card but I've found http://downloadcenter.intel.com/filter_results.aspx?strTypes=all&ProductID=2773&OSFullName=Linux*&lang=eng&strOSs=39&submit=Go%21  that supports my card but driver I have to force it using ignoreABI and is not stable.
Comment 1 Djalma B. Martins 2009-12-31 19:38:57 UTC
(In reply to comment #0)
> I have a [SiS] 771/671 PCIE VGA Display Adapter [1039:6351] (rev 10) driver
> from xorg doesn't have support for my card but I've found
> http://downloadcenter.intel.com/filter_results.aspx?strTypes=all&ProductID=2773&OSFullName=Linux*&lang=eng&strOSs=39&submit=Go%21
>  that supports my card but driver I have to force it using ignoreABI and is not
> stable.
> 

There is a driver in Mandriva that supports this card (see https://qa.mandriva.com/show_bug.cgi?id=50419). 

The source code is here: 
http://mandriva.c3sl.ufpr.br/official/2010.0/SRPMS/main/release/x11-driver-video-sisimedia-0.9.1-1.20090622.2mdv2010.0.src.rpm

The license is MIT. Could it be included in Xorg?
Comment 2 Pablo Castellano (pablog) 2010-09-14 11:09:45 UTC
Is there any way that I can help with this bug? By default vga16fb is used and it doesn't allow any resolution higher than 800x600, which is annoying.
Comment 3 Pander 2010-10-12 03:52:10 UTC
Please get the latest from https://bugs.launchpad.net/xorg-server/+bug/301958 which is pointing to http://ajoliveira.com/ajoliveira/uk/software/xorg.php

Note, resolutions higher than 800x600 *are* possible.

Please fix this bug which is more than two years old so the driver can get into the next release and eventually be packaged by Ubuntu to be enjoyed by all.
Comment 4 Timo Aaltonen 2011-03-21 15:06:24 UTC
*** Bug 29668 has been marked as a duplicate of this bug. ***
Comment 5 Pander 2013-04-27 12:36:26 UTC
Please restore support for this driver. See https://bugs.launchpad.net/debian/+source/xserver-xorg-video-sis/+bug/301958 It was working (somewhat) up to Ubuntu 12.04 but on 12.10 and on 13.04 it does not work anymore.

the work of Antonio J. de Oliveira (ajoliveira) can be used but someone of Xorg should help out on this.

Fixing this would again enable using Xorg on many laptops with Sis 771/671 graphic cards.
Comment 6 Pander 2013-04-29 13:10:33 UTC
I would be more than happy to provide financial support or compensation for whoever fixes this bug. We could create feature request funding at https://www.catincan.com/
Comment 7 Pander 2013-05-10 08:36:34 UTC
Good news, here is a workable driver but without acceleration at the moment:
  http://lists.x.org/archives/xorg-devel/2013-May/036222.html
Comment 8 Ildar Muyukov 2013-06-17 07:42:50 UTC
https://bugs.freedesktop.org/show_bug.cgi?id=14848 seems dup of this bug (even though older)
Comment 9 Ildar Muyukov 2013-06-17 07:57:32 UTC
(In reply to comment #7)
> Good news, here is a workable driver but without acceleration at the moment:
>   http://lists.x.org/archives/xorg-devel/2013-May/036222.html

This is just great!
But could anyone please point to the source code with all appropriate patches applied? Is gitorious repo most current?
Comment 10 mirh 2017-04-28 19:21:29 UTC
(In reply to Ildar Muyukov from comment #9)
> This is just great!
> But could anyone please point to the source code with all appropriate
> patches applied? Is gitorious repo most current?

https://github.com/gununu/xf86-video-sis-stable

I'm not sure if this supersede or complement Arch patches though https://github.com/rkrell/xf86-video-sisimedia
Comment 11 GitLab Migration User 2018-08-10 20:47:27 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xorg/driver/xf86-video-sis/issues/6.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.