Bug 1544 - New locale si_LK
New locale si_LK
Status: CLOSED FIXED
Product: xorg
Classification: Unclassified
Component: * Other
unspecified
x86 (IA32) All
: high enhancement
Assigned To: Roland Mainz
http://cvs.linux.lk/cgi-bin/cvsweb/si...
:
: 1274 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-05 22:22 UTC by Anuradha Ratnaweera
Modified: 2011-10-15 16:23 UTC (History)
7 users (show)

See Also:
i915 platform:
i915 features:


Attachments
This patch adds si_LK locale to the locale list. (1.83 KB, patch)
2004-10-05 22:24 UTC, Anuradha Ratnaweera
no flags Details | Splinter Review
Adds Sinhala to xc/programs/Xserver/XpConfig/Imakefile (2.29 KB, patch)
2004-10-08 05:38 UTC, Anuradha Ratnaweera
no flags Details | Splinter Review
Removed the doubtful locale ID (1.98 KB, patch)
2004-11-04 23:48 UTC, Anuradha Ratnaweera
no flags Details | Splinter Review
Diff for checkin (same as attachment 1227 but includes Changelog entry), patch for 2004-11-08-trunk (9.33 KB, patch)
2004-11-08 16:55 UTC, Roland Mainz
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Anuradha Ratnaweera 2004-10-05 22:22:21 UTC
The locale si_LK is not in X.org server locale list.
Comment 1 Anuradha Ratnaweera 2004-10-05 22:22:55 UTC
*** Bug 1274 has been marked as a duplicate of this bug. ***
Comment 2 Anuradha Ratnaweera 2004-10-05 22:24:15 UTC
Created attachment 1021 [details] [review]
This patch adds si_LK locale to the locale list.

This patch is included in the Sinhala GNU/Linux distribution from
http://sinhala.linux.lk .
Comment 3 Roland Mainz 2004-10-07 23:20:41 UTC
Anuradha Ratnaweera:
xc/programs/Xserver/XpConfig/Imakefile need to be updated, too.
Comment 4 Anuradha Ratnaweera 2004-10-08 05:38:36 UTC
Created attachment 1037 [details] [review]
Adds Sinhala to xc/programs/Xserver/XpConfig/Imakefile

In addition to nls/compose.dir, nls/locale.dir and nls/locale.alias, this patch
adds Sinhala to xc/programs/Xserver/XpConfig/Imakefile.
Comment 5 Leon Ho 2004-10-25 17:30:29 UTC
The patch looks okay to me.
Comment 6 Anuradha Ratnaweera 2004-10-25 22:12:04 UTC
If there is a doubt abuout the use of "Sinhala" instead of "Sinhalese", please
refer to this amendment to ISO 639:

http://www.loc.gov/standards/iso639-2/langcodes.html
Comment 7 Roland Mainz 2004-11-04 17:02:33 UTC
ienup:
Is the patch OK for you, too ? If "yes" then I am going to commit it...
Comment 8 Ienup Sung 2004-11-04 17:52:26 UTC
I checked the changes suggested and found all of them looks fine except the
Sinhala_Sri Lanka.1115 at the locale.alias patch since I have no idea whether
MSFT CP1115(?) is available and maps to UTF-8.
Comment 9 Roland Mainz 2004-11-04 18:22:06 UTC
Ienup Sung wrote:
> I checked the changes suggested and found all of them looks fine except the
> Sinhala_Sri Lanka.1115 at the locale.alias patch since I have no idea whether
> MSFT CP1115(?) is available and maps to UTF-8.

Anuradha Ratnaweera:
Can you give us some information about that detail, please ?
Comment 10 Ienup Sung 2004-11-04 18:39:31 UTC
(In reply to comment #9)
> Anuradha Ratnaweera:
> Can you give us some information about that detail, please ?

I'm not aware of MSFT/OEM code pages number 1115 or locale name and so
unfortunately I cannot really tell about it. The only thing that
I know is that IBM-1115 is a PC SBCS for China.
Comment 11 Roland Mainz 2004-11-04 18:51:27 UTC
ienup.sung@sun.com wrote:
> (In reply to comment #9)
> > Anuradha Ratnaweera:
> > Can you give us some information about that detail, please ?
>
> I'm not aware of MSFT/OEM code pages number 1115 or locale name and so
> unfortunately I cannot really tell about it. The only thing that
> I know is that IBM-1115 is a PC SBCS for China.

The request in comment #9 was more for Anuradha Ratnaweera - he should post some
pointers (e.g. URLs to specs/documentation/etc.) for the 1115-thing if possible
that we can verify whether that part is correct or not...
Comment 12 Anuradha Ratnaweera 2004-11-04 20:20:27 UTC
(In reply to comment #11)
> 
> The request in comment #9 was more for Anuradha Ratnaweera - he should post some
> pointers (e.g. URLs to specs/documentation/etc.) for the 1115-thing if possible
> that we can verify whether that part is correct or not...

I was using the list of locale IDs (LCID) assigned by Microsoft as in the
following URIs (or many others if you search for the string "Sinhalese" in
micorosoft.com domain).

http://www.microsoft.com/globaldev/reference/lcid-all.mspx?gssnb=1
http://office.microsoft.com/en-us/assistance/HP052590231033.aspx

Also notice that the name of the language in ISO 639 was very recently changed
to Sinhala (see comment #6 from me) to reflect the common usage.  A discussion
related to the use of "Sinhala" instead of "Sinhalese" in GNOME (on the Sinhala
GNU/Linux list) can be found in the following threads.

http://mail.linux.lk/lurker/thread/20041025.062514.d419f153.en.html
http://mail.linux.lk/lurker/thread/20041018.114609.68bc963f.en.html

Both KDE and GNOME are now using the language name as "Sinhala":

http://developer.gnome.org/projects/gtp/teams.html
http://i18n.kde.org/teams/index.php

Glibc locale we have submitted (and reviewed) also uses "Sinhala":

http://sources.redhat.com/bugzilla/show_bug.cgi?id=367
http://cvs.linux.lk/cgi-bin/cvsweb/sinhala/locale/si_LK
Comment 13 Ienup Sung 2004-11-04 22:16:21 UTC
(In reply to comment #12)
MSFT's setlocale also accepts quite similar forms of locale names and their rule
is shown at the following convention:

locale  "lang[_country_region[.code_page]]"
            | ".code_page"
            | ""
            | NULL

In other words, the .code_page cannot be LCID but it has to be CPID.
Hence, the use of .1115 isn't really necessary. Since I have no data in what
would be the correct lang and country values, I also have no idea whether
Sinhala_Sri Lanka would be appropriate. If I were you, I would contact
MSFT people and ask them directly if they have assigned any values for
lang and country for Sinhala an Sri Lanka. Until that is clear, perhaps
not including the Sinhala_Sri Lanka.1115 for now seems appropriate in
my opinion. Other patches look find to me, I'd like to point out again.
Comment 14 Anuradha Ratnaweera 2004-11-04 23:48:42 UTC
Created attachment 1227 [details] [review]
Removed the doubtful locale ID

Thanks Ienup and others for reviewing the patch.  Removed the doubtful locale
ID.  Updated patch has everything else except that line.
Comment 15 Roland Mainz 2004-11-07 21:36:00 UTC
Ienup:
Is the new patch (attachment 1227 [details] [review]) OK for you ?
Comment 16 Ienup Sung 2004-11-08 09:35:59 UTC
(In reply to comment #15)
> Ienup:
> Is the new patch (attachment 1227 [details] [review] [edit]) OK for you ?

Yes, it looks fine to me.
Comment 17 Roland Mainz 2004-11-08 10:05:02 UTC
OK, I'll commit the patch later today...

----

Reassigning bug to myself to add it to my work queue...
Comment 18 Roland Mainz 2004-11-08 16:55:10 UTC
Created attachment 1245 [details] [review]
Diff for checkin (same as attachment 1227 [details] [review] but includes Changelog entry), patch for 2004-11-08-trunk
Comment 19 Roland Mainz 2004-11-08 16:57:50 UTC
Patch checked-in...

/cvs/xorg/xc/ChangeLog,v  <--  ChangeLog
new revision: 1.512; previous revision: 1.511
/cvs/xorg/xc/nls/compose.dir,v  <--  compose.dir
new revision: 1.6; previous revision: 1.5
/cvs/xorg/xc/nls/locale.alias,v  <--  locale.alias
new revision: 1.6; previous revision: 1.5
/cvs/xorg/xc/nls/locale.dir,v  <--  locale.dir
new revision: 1.5; previous revision: 1.4
/cvs/xorg/xc/programs/Xserver/XpConfig/Imakefile,v  <--  Imakefile
new revision: 1.4; previous revision: 1.3
Mailing the commit message to xorg-commit@pdx.freedesktop.org...

... marking bug as FIXED.
Comment 20 Anuradha Ratnaweera 2004-11-22 02:31:06 UTC
This bug doesn't seem to be in the CVS after the server compromise.  Please
correct me if I am wrong.
Comment 21 Anuradha Ratnaweera 2004-11-26 00:04:59 UTC
Noticed that the patch is in the CVS "again".  Sorry about the noice.  Thanks.